Bug 1003938 - impl_qpid changes to allow use of qpid federation
impl_qpid changes to allow use of qpid federation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
3.0
Unspecified Unspecified
high Severity medium
: async
: 4.0
Assigned To: Terry Wilson
Rami Vaknin
:
Depends On: 1003937 1003942 1003946 1003951
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 10:34 EDT by Russell Bryant
Modified: 2016-04-26 18:09 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-3.el6ost.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003937
Environment:
Last Closed: 2013-12-19 19:23:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1178375 None None None Never

  None (edit)
Description Russell Bryant 2013-09-03 10:34:19 EDT
+++ This bug was initially created as a clone of Bug #1003937 +++

A patch was recently merged upstream to the impl_qpid rpc driver to allow the use of qpid federation.  It also completes the fix for leaking qpid exchanges.  Lastly, it includes a couple of additional options to allow durable and auto-delete for queues to be configurable.  Pulling in these options make for a cleaner backport.

The commits from oslo-incubator are:

76972e2 Support a new qpid topology
5ff534d Add config for amqp durable/auto_delete queues


These changes should be backported for RHOS 3.0.z.
Comment 1 lpeer 2013-11-06 07:55:31 EST
For testing this look at comment #9 on BZ 1003946
Comment 3 Rami Vaknin 2013-11-17 23:35:19 EST
According to https://bugzilla.redhat.com/show_bug.cgi?id=1003946#c9, this bug should be tested by setting qpid_topology_version=2, I can find this config param only in heat, ceilometer, nova and cinder.

I've tried to set it also in neutron.conf, the server starts successsfully however I'm not sure whether this conf param is good for all OpenStack components, so:

1. Can I use the "qpid_topology_version=2" config param to all OpenStack components?
2. How can I verify that a component do use qpid federation?


# grep -R qpid_topology_version /etc/
/etc/cinder/cinder.conf:#qpid_topology_version=1
/etc/heat/heat.conf:#qpid_topology_version=1
/etc/heat/heat.conf.bak:#qpid_topology_version=1
/etc/ceilometer/ceilometer.conf:#qpid_topology_version=1
/etc/nova/nova.conf:#qpid_topology_version=1
Comment 4 Russell Bryant 2013-11-18 09:08:56 EST
(In reply to Rami Vaknin from comment #3)
> According to https://bugzilla.redhat.com/show_bug.cgi?id=1003946#c9, this
> bug should be tested by setting qpid_topology_version=2, I can find this
> config param only in heat, ceilometer, nova and cinder.
> 
> I've tried to set it also in neutron.conf, the server starts successsfully
> however I'm not sure whether this conf param is good for all OpenStack
> components, so:
> 
> 1. Can I use the "qpid_topology_version=2" config param to all OpenStack
> components?

I can confirm that this option is supported in Neutron for RHOS 4.0.  Missing from the sample configuration file is a bug, though.


> 2. How can I verify that a component do use qpid federation?

Don't worry about this part.  Federation is still not going to work (according to William Henry).

Just verify that Neutron still works as usual with this option set.  You should notice no difference as a user.
Comment 5 Rami Vaknin 2013-11-19 11:01:44 EST
I've added the the "qpid_topology_version=2" to nova, heat, ceilometer, cinder and neutron, I ran my neutron-robot test, no regression founds.

Tested on:
rhos 4.0 on rhel 6.5, puddle 2013-11-15.1
openstack-neutron-2013.2-7.el6ost

In addition, I've opened the following bug based on rbryant's comment#4:
https://bugzilla.redhat.com/show_bug.cgi?id=1032151

Ami, would your team run a further nova/heat/ceilometer/cinder tests? or do you prefer to set this bug as Verified relying on this comment?
Comment 6 Ami Jeain 2013-11-19 14:34:05 EST
verified on latest puddle from Nov 18.
Ran basic nova tests, creating VM, instance, pausing and resuming an instance, creating volume and deleting volume.
Watched log files for error... no errors found
Comment 10 errata-xmlrpc 2013-12-19 19:23:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.