Bug 1003959 - Make "Nothing to do" error from yum in Puppet installs a little easier to decipher
Make "Nothing to do" error from yum in Puppet installs a little easier to dec...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Martin Magr
yeylon@redhat.com
:
: 1003957 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 10:54 EDT by Perry Myers
Modified: 2016-04-18 02:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.11.dev806.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 18:59:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 47805 None None None Never

  None (edit)
Description Perry Myers 2013-09-03 10:54:44 EDT
From this discussion:
http://openstack.redhat.com/forum/discussion/519/puppet-fails-to-set-openvswitch-from-absent-to-present/p1

It's clear that the current error messages from yum when package installation fails are not really good enough.  Yum will just say "Nothing to do" which doesn't tell the user what really happened.

What we should do is have Packstack catch that sort of error from Yum/Puppet and let the user know that the issue is that the package in question was a dependency and it failed to install for some reason.
Comment 1 Martin Magr 2013-09-20 10:05:53 EDT
*** Bug 1003957 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.