Bug 1003977 - Disconnecting during copy-paste causes copy-paste + context menu to stop working
Summary: Disconnecting during copy-paste causes copy-paste + context menu to stop working
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent
Version: 6.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-03 15:39 UTC by Milan Barta
Modified: 2015-10-28 00:19 UTC (History)
5 users (show)

(edit)
Clone Of:
: 1006200 (view as bug list)
(edit)
Last Closed: 2013-11-21 06:25:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1560 normal SHIPPED_LIVE spice-vdagent bug fix and enhancement update 2013-11-20 21:40:19 UTC

Description Milan Barta 2013-09-03 15:39:17 UTC
Description of problem:
When remote-viewer window is closed during copying of a large amount of data (e.g. contents of /usr/share/dict/words) from client to guest and reconnecting again, the copy-paste function stops working. Furthermore, clicking the left mouse button to call the context menu also no longer works.

Only restarting the vdagent service restores both functionalities. 

Version-Release number of selected component (if applicable):
Host/Client/Guest: RHEL 6.5 x86_64

spice-vdagent-0.14.0-1.el6.x86_64
qemu-kvm-0.12.1.2-2.398.el6.x86_64
spice-gtk-0.20-7.el6.x86_64
spice-server-0.12.4-3.el6.x86_64
virt-viewer-0.5.6-7.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a RHEL 6.5 guest with vdagent running
2. Copy a large amount of text from client to guest
3. During the process, disconnect by closing the remote-viewer window
4. Reconnect (no text should be pasted in guest)
5. Try pasting some text to the guest or calling any context menu (by clicking the left mouse button)

Actual results:
The copy-paste function no longer works and context menu doesn't show up.

Expected results:
Copy-paste works after reconnection and calling context menus works as expected.

Additional info:

Comment 1 Hans de Goede 2013-09-09 14:06:39 UTC
Thanks for the bug-report. I've reproduced, debugged and wrote a fix for this.

This is fixed by this commit:
http://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=ad6ea7594a11d8a35be84a8ae2e8403ea3344a3b

Adding devel-ack.

Comment 2 Hans de Goede 2013-09-10 13:01:27 UTC
Fixed in spice-vdagent-0.14.0-2.el6 moving to modified.

Comment 5 errata-xmlrpc 2013-11-21 06:25:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1560.html


Note You need to log in before you can comment on or make changes to this bug.