Bug 1006200 - Disconnecting during copy-paste causes copy-paste + context menu to stop working
Disconnecting during copy-paste causes copy-paste + context menu to stop working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-vdagent (Show other bugs)
7.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 04:31 EDT by Hans de Goede
Modified: 2014-03-11 03:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: spice-vdagent-0.14.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003977
Environment:
Last Closed: 2014-03-11 03:34:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-09-10 04:31:11 EDT
Cloning bug 1003977 for RHEL-7 since RHEL-7 is affected too.

+++ This bug was initially created as a clone of Bug #1003977 +++

Description of problem:
When remote-viewer window is closed during copying of a large amount of data (e.g. contents of /usr/share/dict/words) from client to guest and reconnecting again, the copy-paste function stops working. Furthermore, clicking the left mouse button to call the context menu also no longer works.

Only restarting the vdagent service restores both functionalities. 

Version-Release number of selected component (if applicable):
Host/Client/Guest: RHEL 6.5 x86_64

spice-vdagent-0.14.0-1.el6.x86_64
qemu-kvm-0.12.1.2-2.398.el6.x86_64
spice-gtk-0.20-7.el6.x86_64
spice-server-0.12.4-3.el6.x86_64
virt-viewer-0.5.6-7.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a RHEL 6.5 guest with vdagent running
2. Copy a large amount of text from client to guest
3. During the process, disconnect by closing the remote-viewer window
4. Reconnect (no text should be pasted in guest)
5. Try pasting some text to the guest or calling any context menu (by clicking the left mouse button)

Actual results:
The copy-paste function no longer works and context menu doesn't show up.

Expected results:
Copy-paste works after reconnection and calling context menus works as expected.

Additional info:

--- Additional comment from Hans de Goede on 2013-09-09 10:06:39 EDT ---

Thanks for the bug-report. I've reproduced, debugged and wrote a fix for this.

This is fixed by this commit:
http://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=ad6ea7594a11d8a35be84a8ae2e8403ea3344a3b

Adding devel-ack.
Comment 1 Hans de Goede 2013-09-10 05:02:11 EDT
This is fixed in spice-vdagent-0.14.0-5.el7 moving to MODIFIED.
Comment 3 Hans de Goede 2014-03-11 03:34:19 EDT
This has long been fixed, closing this with a resolution of CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.