Bug 1004006 - [abrt] ibus-1.5.3-1.fc19: panel_switch_engine: Process /usr/libexec/ibus-ui-gtk3 was killed by signal 6 (SIGABRT) [NEEDINFO]
[abrt] ibus-1.5.3-1.fc19: panel_switch_engine: Process /usr/libexec/ibus-ui-g...
Status: CLOSED DUPLICATE of bug 1037999
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:6d8a757ef0c4bf260d6e39481e8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 13:15 EDT by tom.suzuki
Modified: 2013-12-11 04:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 04:14:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tfujiwar: needinfo? (tom.suzuki)


Attachments (Terms of Use)
File: backtrace (17.06 KB, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: core_backtrace (8.48 KB, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: dso_list (8.01 KB, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: environ (741 bytes, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: maps (34.59 KB, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: open_fds (820 bytes, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details
File: proc_pid_status (935 bytes, text/plain)
2013-09-03 13:15 EDT, tom.suzuki
no flags Details

  None (edit)
Description tom.suzuki 2013-09-03 13:15:26 EDT
Description of problem:
Initially, ibus daemon was not running when I first visited Fedora>Preferences>Input Method Selector.  After being prompted when selectin the iBus method, the iBus daemon was started through the choice.  However, it fell over eventually.

Version-Release number of selected component:
ibus-1.5.3-1.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: panel_switch_engine
executable:     /usr/libexec/ibus-ui-gtk3
kernel:         3.10.10-200.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Sep  3 17:47:57 stelline abrt[9023]: Saved core dump of pid 9010 (/usr/libexec/ibus-ui-gtk3) to /var/tmp/abrt/ccpp-2013-09-03-17:47:57-9010 (14462976 bytes)

Truncated backtrace:
Thread no. 1 (9 frames)
 #4 panel_switch_engine at panel.c:3481
 #5 panel_update_engines at panel.c:4122
 #6 panel_set_config at panel.c:1574
 #7 application_config_name_owner_changed_cb at application.c:308
 #8 _application_config_name_owner_changed_cb_gd_bus_signal_callback at application.c:180
 #9 emit_signal_instance_in_idle_cb at gdbusconnection.c:3715
 #14 gtk_main at gtkmain.c:1156
 #15 application_run at application.c:217
 #16 application_main at application.c:340

Potential duplicate: bug 862031
Comment 1 tom.suzuki 2013-09-03 13:15:30 EDT
Created attachment 793283 [details]
File: backtrace
Comment 2 tom.suzuki 2013-09-03 13:15:34 EDT
Created attachment 793284 [details]
File: cgroup
Comment 3 tom.suzuki 2013-09-03 13:15:37 EDT
Created attachment 793285 [details]
File: core_backtrace
Comment 4 tom.suzuki 2013-09-03 13:15:40 EDT
Created attachment 793286 [details]
File: dso_list
Comment 5 tom.suzuki 2013-09-03 13:15:44 EDT
Created attachment 793287 [details]
File: environ
Comment 6 tom.suzuki 2013-09-03 13:15:47 EDT
Created attachment 793288 [details]
File: limits
Comment 7 tom.suzuki 2013-09-03 13:15:50 EDT
Created attachment 793289 [details]
File: maps
Comment 8 tom.suzuki 2013-09-03 13:15:53 EDT
Created attachment 793290 [details]
File: open_fds
Comment 9 tom.suzuki 2013-09-03 13:15:57 EDT
Created attachment 793291 [details]
File: proc_pid_status
Comment 10 fujiwara 2013-09-05 22:46:05 EDT
(In reply to tom.suzuki from comment #1)
> Created attachment 793283 [details]
> File: backtrace

> #0  0x000000372dc35a19 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
> #1  0x000000372dc37128 in __GI_abort () at abort.c:90
> #2  0x000000373006bbc6 in g_assertion_message (domain=domain@entry=0x41947d "IBUS", file=file@entry=0x41aac1 "panel.c", line=line@entry=3481, func=func@entry=0x41b640 <__PRETTY_FUNCTION__.53329> "panel_switch_engine", message=<optimized out>) at gtestutils.c:1912
> #3  0x000000373006bc24 in g_assertion_message_expr (domain=domain@entry=0x41947d "IBUS", file=file@entry=0x41aac1 "panel.c", line=line@entry=3481, func=func@entry=0x41b640 <__PRETTY_FUNCTION__.53329> "panel_switch_engine", expr=expr@entry=0x41b010 "i >= 0 && i < m_engines.length") at gtestutils.c:1923
> #4  0x00000000004117f7 in panel_switch_engine (self=0x244c390, i=<optimized out>, force=<optimized out>) at panel.c:3481
> #5  0x000000000041227e in panel_update_engines (self=self@entry=0x244c390, var_engines=var_engines@entry=0x7fcec40d7e30, var_order=var_order@entry=0x7fcec400a4d0) at panel.c:4122
> #6  0x0000000000412a96 in panel_set_config (self=0x244c390, config=<optimized out>) at panel.c:1574
> #7  0x000000000040842d in application_config_name_owner_changed_cb (parameters=<optimized out>, signal_name=<optimized out>, interface_name=<optimized out>, object_path=<optimized out>, sender_name=<optimized out>, connection=<optimized out>, self=0x2407400) at application.c:308


I cannot reproduce your backtrace.
Are you still able to reproduce your backtrace?

Which keymap do you use?
% setxkbmap -query
Comment 11 fujiwara 2013-12-11 04:14:03 EST

*** This bug has been marked as a duplicate of bug 1037999 ***

Note You need to log in before you can comment on or make changes to this bug.