Bug 1004064 - beaker-init command listed in documentation errors out
beaker-init command listed in documentation errors out
Status: CLOSED DUPLICATE of bug 1032377
Product: Beaker
Classification: Community
Component: Doc (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 16:27 EDT by Tim Flink
Modified: 2014-08-12 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 00:17:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2013-09-03 16:27:22 EDT
In the beaker installation documentation at:
http://beaker-project.org/docs/admin-guide/installation.html

It says to run:
su apache -c 'beaker-init -u admin -p testing -e root@localhost'

On my RHEL6.4 server, this errors out every time:
[root@localhost ~]# su apache -c 'beaker-init -u admin -p testing -e root@localhost'
This account is currently not available.

But if I change the command to be the following, it works:
sudo -u apache beaker-init -u admin -p testing -e root@localhost
Comment 2 Nick Coghlan 2013-09-04 00:05:36 EDT
I guess the "su" command requires that the apache user have a login shell defined, which is a bad assumption.
Comment 3 Amit Saha 2013-09-04 00:13:13 EDT
(In reply to Nick Coghlan from comment #2)
> I guess the "su" command requires that the apache user have a login shell
> defined, which is a bad assumption.

su apache -s /bin/bash -c 'beaker-init -u admin -p testing -e root@localhost'

should work.
Comment 4 Dan Callaghan 2013-09-04 03:55:10 EDT
Does it even need to run as apache anymore? I thought the only reason was to avoid it writing to the beaker logs as root, but they go to syslog (or in this case, stderr) now.
Comment 5 Amit Saha 2013-09-04 04:00:40 EDT
(In reply to Dan Callaghan from comment #4)
> Does it even need to run as apache anymore? I thought the only reason was to
> avoid it writing to the beaker logs as root, but they go to syslog (or in
> this case, stderr) now.

Actually yes, I was thinking the same. I don't recall running it as apache. So, we basically need to update our documentation.
Comment 7 Raymond Mancy 2013-11-27 00:17:51 EST

*** This bug has been marked as a duplicate of bug 1032377 ***

Note You need to log in before you can comment on or make changes to this bug.