Bug 1032377 - Minor admin guide corrections.
Minor admin guide corrections.
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: Doc (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.14.4
: ---
Assigned To: Nick Coghlan
Amit Saha
:
: 1004064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 23:27 EST by Raymond Mancy
Modified: 2018-02-05 19:41 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 00:09:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2013-11-19 23:27:55 EST
Description of problem:

Couple of slight problems in the admin guide.

Version-Release number of selected component (if applicable):

I think the following <password> should be wrapped in '':

  $ echo "grant all on <db_name>.* to <user_name> IDENTIFIED BY <password>;"| mysql

(this was tested against mysql 5.5.31)

The following:

  su apache -c 'beaker-init -u admin -p testing -e root@localhost'

Does not work on Fedora18. Instead su apache -s /bin/bash -c needs to be used.
If this also works on RHEL6, then we should update it.
Comment 2 Dan Callaghan 2013-11-20 00:21:10 EST
(In reply to Raymond Mancy from comment #0)
> The following:
> 
>   su apache -c 'beaker-init -u admin -p testing -e root@localhost'
> 
> Does not work on Fedora18. Instead su apache -s /bin/bash -c needs to be
> used.
> If this also works on RHEL6, then we should update it.

I don't think we need to run beaker-init as apache anymore. The original reason was because it would touch log files and leave them owned root, but that doesn't happen anymore since Beaker writes to syslog instead of directly to the log files.
Comment 3 Nick Coghlan 2013-11-27 00:16:29 EST
Second part is already covered by bug 1004064, but we still need the quotes around the password.
Comment 4 Raymond Mancy 2013-11-27 00:17:51 EST
*** Bug 1004064 has been marked as a duplicate of this bug. ***
Comment 5 Nick Coghlan 2013-11-27 02:20:24 EST
On Gerrit: http://gerrit.beaker-project.org/2556
Comment 6 Nick Coghlan 2013-11-27 23:23:06 EST
These changes have been included in the updated installation instructions at:

http://beaker-project.org/docs-release-0.14/admin-guide/installation.html

Note You need to log in before you can comment on or make changes to this bug.