Bug 100412 - gnome-panel hangs when attempting to "Run Program"
gnome-panel hangs when attempting to "Run Program"
Status: CLOSED DUPLICATE of bug 99462
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-22 03:55 EDT by Kenneth Topp
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Topp 2003-07-22 03:55:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030702 Galeon/1.3.6

Description of problem:
This issue happens when I use glibc-57 (anything greater then like -42, in
fact).  It turns out that I had a /etc/X11/applnk/Graphics/xv.desktop file that
had "Name=xv".  It seems that only having two characters caused the bug... I
increased the length and the freeze went away.

I also have a galeon hanger which I hope has the same underlying bug.  When I
save a file, depending on the contents of ~/, I will be able to save or not..
Seems like glibc-57 is triggering a bug in gtk+ (as the graphics freezes, and
glibc doesn't generally have such outstanding bugs).  But I filed it hear anyway

I'll try ximians gtk2 before downgrading to glibc-27.9

Version-Release number of selected component (if applicable):
gnome-panel-2.2.0.1-9

How reproducible:
Always

Steps to Reproduce:
1. get a .desktop file in /etc/X11/applnk/*/ with "Name=aa"
2. Click on the redhat
3. Click on "Run Program..."
    

Actual Results:  dialog pops up, gtk2 freezes, strace notices a segfault

Expected Results:  gtk2 doesn't freeze

Additional info:
Comment 1 Kenneth Topp 2003-07-22 04:10:46 EDT
ximian gtk2 didn't help.. but glibc-27.9 does the trick..  

let me know if I can be of assistence in further debugging.  Seems like an easy
enough case to run through a debugger.  I just discoverd that "known programs"
dropdown..  was wondering why it was loading all desktop files then..  I wonder
who actually uses that dropdown
Comment 2 Bill Nottingham 2003-07-28 15:28:29 EDT
Owen: is this the same as the bug about the file selector that was an underlying
glibc problem?
Comment 3 Owen Taylor 2003-07-28 15:47:00 EDT
Yeah, I'd be pretty positive of that. 

*** This bug has been marked as a duplicate of 99462 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:57:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.