Bug 100423 - evolution very SLOW behavior
evolution very SLOW behavior
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-22 05:32 EDT by Warren Togami
Modified: 2014-01-21 17:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-02 04:45:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2003-07-22 05:32:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
evolution-1.3.x Rawhide through evolution-1.4.3-3 in Severn has exhibited the
following poor performance behaviors.

1) Move the vertical separator betwen the folder choosing pane and preview pane,
and it uses 100% CPU for a strangely high amount of time.    Usually 2-30
seconds.  Moving the horizontal separator in the right pane between the message
pane and preview pane does not exhibit this behavior.

2) Sometimes after LONG uptime of at least a day or two, the first time you go
into Contacts or Calendar causes Evolution to freeze completely with 100% CPU
usage.  It recovers and finally displays my 150 contacts or 7 calendar entries
after 1-5 minutes of 100% CPU usage.  Subsequent clicking on these components
works instantly.  Strangely it doesn't exhibit this behavior immediately after
starting evolution, but only after it had been open for a long time working with
my IMAPS folders.

A few other people reported similar problems, one common theme was everyone had
ATI "mach64" video cards, while one nvidia Geforce user reported it worked fine.
 Sorry not much to go by here.

Version-Release number of selected component (if applicable):
evolution-1.4.3-3
Comment 1 Warren Togami 2003-07-22 05:45:53 EDT
I forgot to mention that the 100% CPU usage tends to be in the X process and not
evolution itself.
Comment 2 Yanko Kaneti 2003-07-22 06:58:42 EDT
I have experienced the behavior in 1) for pretty much every gtk2 based evo
release  but (now on 1.4.3) I not using the beta yet.  My evo runs on rh8 and my
X is on rh9 with Matrox Millenium II video card.

I did some more testing and here it seems to be related to the number of folders
that have been _viewed_ in a session. 
   Right after startup the resize speed is mostly constant (and acceptably fast)
regardles of the number of folders I have, the number of messages in the initial
folder or how much of the tree is expanded/visible in the shell folder tree.  
   The resize speed gradually decreases with every newly viewed folder , after
some time and seen most of my 170+ IMAP&other folders the symptoms described in
1) are clearly visible. Evo doesn't seem to very busy , but X takes most of the
systems resources.
Comment 3 Jeremy Katz 2003-08-06 17:18:25 EDT
Warren - what video card are you seeing this with?  Do you see it in other
gtk2/xft using apps?
Comment 4 Warren Togami 2003-08-06 18:43:03 EDT
I see this on my ATI Mobility (mach64), but others using Matrox and nVidia have
reported similar behavior.
Comment 5 Jeremy Katz 2003-10-14 20:12:54 EDT
Does this get any better with current versions of everything?
Comment 6 Warren Togami 2003-10-15 02:15:42 EDT
Nope.  Still bad in Severn3.
Comment 7 Seth Vidal 2003-11-07 00:41:06 EST
Warren, How many folders do you have in your list?

I can't replicate this at all and I'm wondering if it has something to
do with resizing the tree.
Comment 8 Warren Togami 2003-11-07 01:20:58 EST
About 25 IMAP folders.  I just retested with FC1, and both slownesses
are still really bad here.
Comment 9 Seth Vidal 2003-11-07 01:23:38 EST
Do you have the shortcut bar open, too?
Comment 10 Warren Togami 2003-11-07 01:31:50 EST
Nope, turned that off a long time ago.
Comment 11 Kobus Grobler 2004-04-20 09:18:32 EDT
I have the same problem as in 1) above (high cpu usage in X when
moving vertical bar).
Also - I think I have a way of reproducing it.
This works best if you have a couple (20 or ss) of folders (local or
IMAP).
Open evolution.
Move the vertical bar (it should redraw at an aceptable speed).
Visit all of the folders by clicking on the folder and displaying an
email in that folder (especially those html ones from RedHat :)).
Move the vertical bar and wait.
 
Comment 12 Dave Malcolm 2004-09-27 18:12:47 EDT
Is anyone able to reproduce this bug in Evolution 2.0 ?  I've been
trying the methods described above, but the redraw seems acceptable to
me with this version of the app.
Comment 13 Giovanni Cangiani 2005-04-13 03:09:01 EDT
aaa
Comment 14 Jim Cornette 2005-06-10 19:56:15 EDT
I have been experiencing very slow downloading of messages with evolution. I
estimate 11 seconds per message received.
Comment 15 Warren Togami 2005-06-10 22:32:27 EDT
Jim your problem is likely due to the default use of spamassassin on every
message coupled with DNS lookup problems and unrelated to this bug.
Comment 16 Jim Cornette 2005-06-17 17:17:26 EDT
Thanks for the redirection.
Comment 17 Yanko Kaneti 2005-09-02 03:59:28 EDT
I think its safe to close this one. I haven't seen this problem for more than a
year now and I've been using different evolution releases all the time.

Note You need to log in before you can comment on or make changes to this bug.