Bug 100427 - Please update the templates, and consider putting them into a user-viewable area
Please update the templates, and consider putting them into a user-viewable area
Status: CLOSED DUPLICATE of bug 84777
Product: Red Hat Linux Beta
Classification: Retired
Component: openoffice.org (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2003-07-22 06:12 EDT by Denice
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-28 03:26:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch for the SPEC file (2.21 KB, patch)
2003-08-09 10:16 EDT, Denice
no flags Details | Diff
Newer template files repackaged (561.35 KB, application/octet-stream)
2003-08-09 10:18 EDT, Denice
no flags Details

  None (edit)
Description Denice 2003-07-22 06:12:22 EDT
Description of problem:
There are some newer templates for openoffice available (and no longer in *.vor
format) at:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:
The older versions of templates are in:
Your average user is _never_ going to find them.

Expected results:
It would be much better if, at least with the Impress wizard, that the user
could find the templates.  To get around this problem here with RH 9, I
symlinked the files from /usr/lib/openoffice/share/template/english/ to a
place where I copied them.  It think it would be helpful if the post-install
area of the openoffice RPM ran symlinks from the language directories back to
where the files live, ie, in /usr/lib/openoffice/share/template/english/

At least it would be a start.  In my experience, new openoffice users miss
templates a whole bunch.

Additional info:
Comment 1 Denice 2003-07-22 06:18:44 EDT
I suppose that I might add that I think it is much nicer if the templates are
organized into subdirectories; for example chez nous:

[host /usr/lib/openoffice/share/template/english]$ ls -Lp
Calc:_Spreadsheets/  Impress:_Presentations/  Writer:_Documents/
Draw:_Graphics/      internal/                wizard/

[host /usr/lib/openoffice/share/template/english]$ ls -Lp Calc\:_Spreadsheets
balancesheet.stc  marketing_plan_calc.stc
Comment 2 Denice 2003-08-09 10:15:10 EDT
I am attaching a candidate patch for the openoffice spec file that:
  - would include the newest gallery and english template files, and
  - would sym-link the template files into the language subdirectories in

I am also attaching the repackaged template files.  I stuffed the template files
into subdirs:  Calc/  Draw/  Impress/  Writer/

I think it is nicer to organize shared templates into subdirs that reflect the
name of the application that uses them.  Also, if some day a lot more template
files are added then the list of files becomes annoying long in a single
directory for users who are trying to pick a template.

I won't bother attaching the newer gallery files, as it is 2.4 MB, unless it is
wanted.  I gathered up the zip files at
and stuffed them into a 'gallery/' sub-directory, and b2zipped them.  The new
'clock' files do not seem to contribute much without organising them into a
'theme' - I'm not sure why they are posted on the OO documentation site without
being converted into themes.  I'll look into it.

Note there are some newer dictionary files available also; FYI the newer files are:
  da_DK, de_CH. de_DE, en_GB, es_ES, gl_ES, hu_HU, it_IT, lt_LT, sv_SE

The gl_ES.zip file has an error in it -- it contains a directory; thus to
rebuild it locally I repackaged it. I have informed the maintainer of the web
site at lingucomponent.openoffice.org, so hopefully it will be fixed soon.

I'm willing to go on a hunt for templates in other languages, and push the
maintainers to at least provide zipped files of all; for example:
has no zip files (but has some interesting templates).

Unfortunately, efforts for making templates in general are 'uneven' (in the
sense of everyone doing different things), and sprinkled around the globe. But
perhaps with some templates in place, some users might feel more inclined to
contribute templates in their locale?

Gosh, I think I'll go buy a bigger, faster machine; rebuilding this rpm is too
painful on a 1G machine.  I got clobbered a few times with disk space problems,
and for having '%debug_package %{nil}' in my .rpmmacros file..
Comment 3 Denice 2003-08-09 10:16:39 EDT
Created attachment 93546 [details]
patch for the SPEC file
Comment 4 Denice 2003-08-09 10:18:22 EDT
Created attachment 93547 [details]
Newer template files repackaged
Comment 5 Denice 2003-08-09 16:52:41 EDT
Wow.  I just had email from Richard at lingucomponent.openoffice.org saying that
he is correcting the problem with gl_ES.zip

Sunday night.  Hmmmm...  Either some people in the world don't understand how
open-source works (ie. thousands of odd souls working quietly in the 4 corners
of the world on sunday night for world domination, world peace, etc.), or some
of us _really_ need to get a life, or, more likely, all of the above.
Comment 6 Dan Williams 2004-02-27 11:30:21 EST
combining template bugs/request

*** This bug has been marked as a duplicate of 84777 ***
Comment 7 Caolan McNamara 2004-10-28 03:26:50 EDT
close duplicates

Note You need to log in before you can comment on or make changes to this bug.