Bug 1004421 - f20 SoaS TC3 uses gdm which defaults to gnome. Autologon starts gnome with no chance to choose sugar-desktop
f20 SoaS TC3 uses gdm which defaults to gnome. Autologon starts gnome with no...
Status: CLOSED DUPLICATE of bug 1008569
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20AlphaFreezeException
  Show dependency treegraph
 
Reported: 2013-09-04 11:23 EDT by satellitgo
Modified: 2013-10-02 03:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 03:09:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg logs (19.37 KB, text/x-log)
2013-09-13 13:26 EDT, Paul Whalen
no flags Details

  None (edit)
Description satellitgo 2013-09-04 11:23:32 EDT
Description of problem:f20 SoaS TC3 uses gdm which defaults to gnome. Autologon starts gnome with no chance to choose sugar-desktop. gdm works properly once alt f2 root liveinst is used. This is because there is now a user to login.

See Bz 997478
 sugar-emulator is no longer in f20 to be replaced with sugar-runner (not yet packaged) thus sugar is not present in gnome-desktop
Also see:http://wiki.sugarlabs.org/go/Fedora_20#f20-Alpha_TC2


Version-Release number of selected component (if applicable):
f20 SoaS TC3 x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
To fix:
1- select sugar as default desktop in gdm 
2- Or do not use autologin
Via a .ks change
Comment 1 Kamil Páral 2013-09-04 13:11:20 EDT
Discussed at 2013-09-04 blocker review meeting [1]. This prevents SoaS from booting properly and would be a blocker for a release blocking DE, therefore accepted as a FE for F20 alpha.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-04/
Comment 2 Peter Robinson 2013-09-06 11:01:50 EDT
This should be fixed in the kickstart files now. Once we have a TC5 or RC1 it should be all fixed.
Comment 3 satellitgo 2013-09-09 10:53:52 EDT
f20 TC5 SoaS boots to console login
No DE called
requires login as liveuser then startx 
see:http://wiki.sugarlabs.org/go/Fedora_20
Comment 4 Peter H. Jones 2013-09-12 09:26:26 EDT
I have had also had experience with the problem of wanting to change the desktop environment of the autologin user. I believe system-config-users should have the following added:
1) change the desktop environment, just as the the shell can now be changed,
2) option to suppress appearance of selected users in the user list.

I'm willing to refile if this comment is misplaced.
Comment 5 Paul Whalen 2013-09-13 13:25:27 EDT
Install from DVD on F20 Alpha RC2 X86_64 and the ARM image both boot to multiuser, 'startx' fails. logs attached.
Comment 6 Paul Whalen 2013-09-13 13:26:23 EDT
Created attachment 797448 [details]
xorg logs
Comment 7 Peter Robinson 2013-10-02 03:09:12 EDT

*** This bug has been marked as a duplicate of bug 1008569 ***

Note You need to log in before you can comment on or make changes to this bug.