Bug 1004431 - rhqctl upgrade on windows/postgres failed while rhq.ear deployment
rhqctl upgrade on windows/postgres failed while rhq.ear deployment
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
4.9
x86_64 Windows
unspecified Severity urgent (vote)
: ---
: RHQ 4.9
Assigned To: John Sanda
Mike Foley
:
Depends On: 1004449
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-09-04 11:40 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 15:17:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-09-04 11:40:54 EDT
Description of problem:
rhqctl upgrade on windows/postgres failed while rhq.ear deployment

Version-Release number of selected component (if applicable):
rhq 4.5.1 - rhq 4.9 - build  281e8e

How reproducible:
always

Steps to Reproduce:
1. install an start rhq-server-4.5.1 server with agent
2. run rhqctl.bat upgrade --from-server-dir ${rhq-server-4.5-dir}
3.

Actual results:
org.hibernate.PropertyAccessException: Null value was assigned to a property of primitive type setter of org.rhq.core.domain.cloud.StorageNode.maintenancePending exception in server.log - deployment for rhq.ear is stuck -> "An existing connection was forcibly closed by the remote host" exception in server.log

Expected results:
rhq server and agent upgraded, storage is installed and started without issues

Additional info:
full server.log -> http://d.pr/f/55g2
Comment 1 Armine Hovsepyan 2013-09-04 11:41:37 EDT
OS tyep = Windows 2008
Java Version =  oracle jre 1.7
Rel. DB =  Postgresql 9.2
Comment 2 Heiko W. Rupp 2013-09-05 06:27:07 EDT
With Bug 1004449 solved is that still an issue? 

This looks like a blocker for 4.9
Comment 3 Armine Hovsepyan 2013-09-05 07:30:39 EDT
general upgrade not working issue filed #1004731 - this one can be closed as verified  - deployment for rhq.eap goes forward.

Note You need to log in before you can comment on or make changes to this bug.