Bug 1004450 - [RFE] rpmsodiff return non-zero if rpms differ
[RFE] rpmsodiff return non-zero if rpms differ
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmdevtools (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 12:22 EDT by jcpunk
Modified: 2014-11-01 12:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: rpmdevtools-8.5-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1159875 1159876 (view as bug list)
Environment:
Last Closed: 2014-11-01 12:51:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement behavior (1.19 KB, patch)
2013-09-04 12:22 EDT, jcpunk
no flags Details | Diff

  None (edit)
Description jcpunk 2013-09-04 12:22:37 EDT
Created attachment 793750 [details]
Patch to implement behavior

Description of problem: rpmsodiff provides the difference information I want, but I can't script a check to determine if the rpms match or if they do not.


Version-Release number of selected component (if applicable):rpmdevtools-8.3-5.fc20


How reproducible: always


Steps to Reproduce:
1. run against two identical rpms
2. echo $?
3. run against two different rpms
4. echo $?
5. note it is the same

Actual results:
return code is 0

Expected results:
Like 'diff' if the files don't match return non-zero

Additional info:
Comment 1 jcpunk 2013-11-25 11:01:43 EST
Just wondering if there were any thoughts on this patch.
Comment 2 Ville Skyttä 2013-11-26 02:46:48 EST
Sorry about the delay. The reason I haven't done anything about this yet is that rpmdevtools is not the upstream for rpmsodiff, and I'd prefer this to see fixed upstream instead of carrying a modified version in rpmdevtools.

I suppose the best upstream contacts are the people listed at http://packages.altlinux.org/en/Sisyphus/srpms/qa-robot, will try to ping them.
Comment 3 Gleb Fotengauer-Malinovskiy 2013-11-26 10:37:03 EST
(In reply to jcpunk from comment #0)
> Created attachment 793750 [details]
> Patch to implement behavior

Thank you for idea!
But your patch doesn't work in some cases:
1. in case of no common sonames, it should return 1.
2. in case of common sonames and if symbols differ. In 'while' loop works in subshell, so RETVAL=1 does not affect return code.

My patch works in this cases:
http://git.altlinux.org/people/glebfm/packages/qa-robot.git?p=qa-robot.git;a=shortlog;h=refs/heads/master
Comment 4 Ville Skyttä 2013-11-26 12:16:24 EST
Thanks for looking into this, Gleb!

I'll leave this bug open for tracking purposes until we ship rpmsodiff that includes this feature in Fedora.
Comment 5 Fedora Update System 2014-10-20 14:48:32 EDT
rpmdevtools-8.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rpmdevtools-8.5-1.fc21
Comment 6 Fedora Update System 2014-10-21 13:24:12 EDT
Package rpmdevtools-8.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmdevtools-8.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13380/rpmdevtools-8.5-1.fc21
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-11-01 12:51:34 EDT
rpmdevtools-8.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.