Bug 1004458 - NewPkg: pssh
NewPkg: pssh
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: pssh (Show other bugs)
3.0
Unspecified Unspecified
high Severity medium
: beta
: 4.0
Assigned To: Alan Pevec
Ami Jeain
: FutureFeature
Depends On:
Blocks: RHOS40RFE 995967 1013625
  Show dependency treegraph
 
Reported: 2013-09-04 12:32 EDT by Perry Myers
Modified: 2013-12-19 19:23 EST (History)
14 users (show)

See Also:
Fixed In Version: pssh-2.3.1-4.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1013625 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:23:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
apevec: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-09-04 12:32:21 EDT
Add pssh package to get access to pssh and pslurp to make using sosreport over a cluster of nodes easier.  An example of how this could be done is:

rm -Rf sos && mkdir -p sos && cd sos
pssh -i -H "root@r6m root@localhost" rm -Rfv /tmp/sos
pssh -i -t 0 -H "root@r6m root@localhost" sosreport --tmp-dir /tmp/sos
pslurp -t 0 -H "root@r6m root@localhost" -r /tmp/sos .

As an alternative to -H with a list of hostnames, you can use:

-h hosts.txt

Where hosts.txt contains a line per host like:
root@r6m
root@localhost

We would ship this package in RHOS (from 3.0.z onward) to be solely used and supported for the use case of gathering up sosreports from many hosts.
Comment 1 Alan Pevec 2013-09-04 13:56:15 EDT
Scratch el6 build:
http://kojipkgs.fedoraproject.org//work/tasks/4854/5894854/pssh-2.3.1-5.el6.noarch.rpm

No additional deps are required, pssh uses openssh-clients.
Comment 6 Ami Jeain 2013-11-11 09:08:05 EST
# rpm -qa |grep pssh
pssh-2.3.1-4.el6ost.noarch

ran some basic pssh commands. works fine
Comment 10 errata-xmlrpc 2013-12-19 19:23:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.