Bug 995967 - RFE: RHOS log collector tool
Summary: RFE: RHOS log collector tool
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: sos-plugins-openstack   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: z1
: 4.0
Assignee: Alan Pevec
QA Contact: Udi
URL:
Whiteboard:
Keywords: FutureFeature, OtherQA, ZStream
: 1025852 (view as bug list)
Depends On: 840057 1004458
Blocks: RHOS40RFE
TreeView+ depends on / blocked
 
Reported: 2013-08-12 05:21 UTC by Haim
Modified: 2016-04-26 18:13 UTC (History)
19 users (show)

Fixed In Version: sos-plugins-openstack-2013.2-5.el6ost pssh-2.3.1-5.el6ost
Doc Type: Enhancement
Doc Text:
A new tool for collecting logs, called rhos-logs-collector, has been introduced. There is a knowledge base article with more information available at https://access.redhat.com/site/solutions/472743
Story Points: ---
Clone Of:
: 1033368 (view as bug list)
Environment:
Last Closed: 2014-01-23 14:21:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhos-log-collector script (2.41 KB, text/plain)
2013-11-22 15:15 UTC, Alan Pevec
apevec: review?
Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0046 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-01-23 00:51:59 UTC

Description Haim 2013-08-12 05:21:05 UTC
Description of problem:

I would like to request the following feature\functionality in RHOS:

rhos-log-collector, which is going to be a tool that will collect all needed logs and system state from all nodes in the cluster pending on the configuration. 

i.e:

in a distributed environment, tool will collect all logs from cinder, glance swift and all other components pending on their location. 

we have a similar tool in rhev which collect all logs from the engine (manager) and all hypervisors.

Comment 3 Perry Myers 2013-10-03 09:34:17 UTC
I discussed this with Lon Hohberger/Alan Pevec.  Since we are including pssh/pslurp in RHOS now (bug # 1004458), this bug could be trivially solved via a simple bash script that calls pssh with sosreport on a set of hosts defined in a text file.

I believe Lon or Alan was going to write that script to parse packstack answers file to get a list of hosts, or the user could manually generate.  It could go into the new sos-openstack-modules package where we would be storing the openstack specific sos modules.

An example of what a simple script might look like is available here:
https://bugzilla.redhat.com/show_bug.cgi?id=1004458#c0

Speaking of which, I don't see a bugzilla component for sos-openstack-modules.

Bryn, you were going to drive owning that component correct?

Comment 8 Alan Pevec 2013-11-04 16:39:47 UTC
*** Bug 1025852 has been marked as a duplicate of this bug. ***

Comment 10 Alan Pevec 2013-11-22 15:15:06 UTC
Created attachment 827851 [details]
rhos-log-collector script

Comment 16 Alan Pevec 2013-12-09 13:43:29 UTC
Split log collector into its own subpackage so it can have explicit RPM dep on pssh.

Comment 34 Udi 2014-01-16 08:25:09 UTC
Verified in:
rhos-log-collector-2013.2-5.el6ost.noarch

A new bug, 1054073, was opened regarding the message you get in the output of rhos-log-collector, which points you to find the collected logs in a directory where actually there are only the local node logs.

Comment 37 Lon Hohberger 2014-02-04 17:19:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html


Note You need to log in before you can comment on or make changes to this bug.