Bug 100457 - usermount stuck when run as non-root user
usermount stuck when run as non-root user
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: usermode (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-22 12:29 EDT by Pavel
Modified: 2013-07-02 18:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 10:30:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2003-07-22 12:29:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030721

Description of problem:
When usermount command is run as non-root user, it get stuck - no window
appears. Works fine when run as root.

Version-Release number of selected component (if applicable):
usermode-gtk-1.68-2

How reproducible:
Always

Steps to Reproduce:
1. Run usermount as regular user.
2.
3.
    

Actual Results:  Nothing happens.

Expected Results:  Open user mount tool

Additional info:
Comment 1 Jeremy Portzer 2003-10-22 10:18:46 EDT
usermount works fine for me in Fedora Core test3.  Does this bug still exist for
you in the test3 release?  If so, maybe you could provide an strace or similar
diagnostic as to why it's hanging?
Comment 2 Pavel 2003-10-22 11:57:26 EDT
It works when I log in on the console, but when I log in with remote X session
it's stuck.
Comment 3 Nalin Dahyabhai 2003-10-23 12:23:57 EDT
Should be fixed in 1.69-1 (usermount would hang due to a bug if it tried to
present the "you can't mount anything, contact your sysadmin" dialog).  Thanks!
Comment 4 petrosyan 2003-10-25 14:05:14 EDT
i can confirm that it is fixed in usermode-gtk-1.69-1
Comment 5 Behdad Esfahbod 2003-11-05 08:54:36 EST
Should we close this bug?
Comment 6 Jindrich Novy 2005-01-27 10:30:55 EST
Yep, it works fine with the recent usermode.

Note You need to log in before you can comment on or make changes to this bug.