Bug 1004575 - [Doc] We shouldn't specify add both V2 and V3 identity endpoints
[Doc] We shouldn't specify add both V2 and V3 identity endpoints
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Scott Radvan
ecs-bugs
: Documentation, Triaged
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-09-04 21:35 EDT by Jamie Lennox
Modified: 2015-10-25 21:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.11 Build Name: 15807, Installation and Configuration Guide-null-1 Build Date: 08-08-2013 15:00:52 Topic ID: 15935-447432 [Latest]
Last Closed: 2014-01-05 19:03:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1219584 None None None Never

  None (edit)
Description Jamie Lennox 2013-09-04 21:35:28 EDT
In section 5.6 of https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html-single/Installation_and_Configuration_Guide/index.html#Creating_the_Permanent_Service_Endpoint we say to add the v2 endpoint and then the v3 endpoint. 

Currently you can't have multiple endpoints for the same service - it's allowed but there is no way to distinguish between them so the last added will always win.

This means that v3 will win, and v3 is not supported by the keystone CLI application, and is only starting to be supported by other services. 

For now we should not add the v3 endpoint and simply allow people to work with v2. In the future we should provide the base url as the endpoint and the services will query it to find that there is a v2 and v3 endpoint available and let it use the most appropriate but i don't think that is ready yet. 

Originally brought up: http://openstack.redhat.com/forum/discussion/comment/1469
Comment 2 Summer Long 2013-09-05 20:05:27 EDT
Per Jamie, the gist is that, right now, if you install v3, it will always be the default. And the client errors out because it can't cope. So Jamie's solution (and he talked to other dev folks as well) is to not mention the v3 api at all. It shouldn't have any effect on the other services. 
So perhaps just comment it out so that it can later be used if needed.

Note You need to log in before you can comment on or make changes to this bug.