This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004615 - gnome-tweak-tool fails to show "Windows" tab on some Fedora 19 systems
gnome-tweak-tool fails to show "Windows" tab on some Fedora 19 systems
Status: CLOSED DUPLICATE of bug 1003927
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool (Show other bugs)
19
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 00:11 EDT by Maxwell Spangler
Modified: 2013-09-05 06:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 06:42:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-tweak-tool run as user maxwell; Failure showing "Windows" tab. (7.08 KB, text/plain)
2013-09-05 00:11 EDT, Maxwell Spangler
no flags Details
gnome-tweak-tool run as user root; Success showing "Windows" tab. (5.56 KB, text/plain)
2013-09-05 00:12 EDT, Maxwell Spangler
no flags Details
dconf-editor gui display of org.gnome.desktop.wm.preferences keys as user maxwell (114.22 KB, image/png)
2013-09-05 00:21 EDT, Maxwell Spangler
no flags Details

  None (edit)
Description Maxwell Spangler 2013-09-05 00:11:27 EDT
Created attachment 793981 [details]
gnome-tweak-tool run as user maxwell; Failure showing "Windows" tab.

Description of problem:

Some of us are seeing multiple Fedora 19 installations where gnome-tweak-tool fails to show the "Windows" tab that allows configuration of window related features such as Window focus mode and title bar click-actions.

On my primary desktop I've noticed that if I run gnome-tweak-tool as root, it works fine, but not as my user, 'maxwell'.

"gnome-tweak-tool --debug" suggests that there are configuration variables missing:

INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key theme)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key action-double-click-titlebar)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key action-middle-click-titlebar)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key action-right-click-titlebar)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key focus-mode)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key mouse-button-modifier)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key resize-with-right-button)
INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key raise-on-click)

INFO    : GSettings missing key org.gnome.desktop.wm.preferences (key titlebar-font)

I'll post a complete --debug output for root and user on my system as attachments.

Version-Release number of selected component (if applicable):
Fedora 19, fresh install.  Updated to 2013.0904.

How reproducible:
Consistent, on this system and one other.
Seen by other users in this fedoraforum thread:
http://www.forums.fedoraforum.org/showthread.php?p=1667731&posted=1#post1667731

Steps to Reproduce:
1. Install Fedora 19
2. Create user
3. Run gnome-tweak-tool as user
4. Observe whether the "Windows" tab is present
5. Failure = No "Windows"

Actual results:
--debug errors when run by my user.

Expected results:
A visible "Windows" tab and the ability to configure WM options.

Additional info:
It's possible that gnome-tweak-tool is not the root of this problem and that whatever creates a default configuration database is not doing so properly.  That said, it would be very nice if gtt would identify missing values and create defaults for them so users can configure as needed without having to use gconfeditor.
Comment 1 Maxwell Spangler 2013-09-05 00:12:28 EDT
Created attachment 793982 [details]
gnome-tweak-tool run as user root; Success showing "Windows" tab.
Comment 2 Maxwell Spangler 2013-09-05 00:21:14 EDT
Created attachment 793983 [details]
dconf-editor gui display of org.gnome.desktop.wm.preferences keys as user maxwell

The attached dconf-editor screenshot shows that I have some keys that gnome-tweak-tool --debug is complaining about.  I used dconf-editor to manually change settings like "num-workspaces" and "focus-mode" to work-around the missing "Windows" tab in gnome tweak tool in the past.

I was expecting these keys to be missing completely.
Comment 3 Mohamed El Morabity 2013-09-05 06:42:18 EDT

*** This bug has been marked as a duplicate of bug 1003927 ***

Note You need to log in before you can comment on or make changes to this bug.