Bug 100470 - (NET 3C59X) 3c59x doesn't work with 3Com PCI 3c905 NIC
(NET 3C59X) 3c59x doesn't work with 3Com PCI 3c905 NIC
Status: CLOSED DUPLICATE of bug 98767
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-22 15:10 EDT by Vaclav "sHINOBI" Misek
Modified: 2013-07-02 22:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant part of message log (3.52 KB, text/plain)
2003-07-22 15:12 EDT, Vaclav "sHINOBI" Misek
no flags Details

  None (edit)
Description Vaclav "sHINOBI" Misek 2003-07-22 15:10:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
The card doesn't work, unable to bing anywhere.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. reboot
2. ping anywhere (except localhost or my IP)
3.
    

Actual Results:  Host unreachable error message.

Expected Results:  Working network.

Additional info:

When I put the 8139too compatible NIC, to the same PCI slot, everything works.
Comment 1 Vaclav "sHINOBI" Misek 2003-07-22 15:12:22 EDT
Created attachment 93054 [details]
Relevant part of message log
Comment 2 malcolm 2003-07-23 14:13:00 EDT
tried 3c900 and 3c905 neither work - mal 
Comment 3 Nathan G. Grennan 2003-07-23 14:55:46 EDT
Try the kernel boot option acpi=off

Check out https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100522 for more
details.
Comment 4 Vaclav "sHINOBI" Misek 2003-07-23 15:00:20 EDT
Tried with this boot option, but network still doesn't work.
Comment 5 malcolm 2003-07-30 15:39:23 EDT
Rebuilt the kernel and put 3c900  in it rather than a module and it worked 
( broke a few things :-) but networking was fine - hope that helps - mal 
Comment 6 Warren Togami 2003-09-21 07:23:02 EDT
Does that 3c905 card work in other operating systems or other brands of Linux?
Do you have identical cards, and they all exhibit this problem?

I have several dozen of those cards.  Sometimes a few of them stop working
properly either completely or slow-down inexplicably.  It turns out that the
card has hit its end of life, so I just toss it and replace it with another. 
Otherwise I have had no problems with the RHL drivers for those cards in over
two years.

Please be sure that particular card is not the problem.
Comment 7 malcolm 2003-09-21 09:02:19 EDT
Both cards I tried worked in RH9, Suse 8.2 and XP
The machine had XP, Suse8.2 and Servern and if you boot to the other OSs
it works fine - then I switched the Suse partition to RH9 and that worked
too - anyway I got fed up and put a US Robotics network card in and that
is fine for everything

Interestingly if you build the driver into the kernel that also works
the problem only happens with Severn and the 3com as a loadable module

However I do love the idea of a geriatric network card slowing down :-)


 
Comment 8 Vaclav "sHINOBI" Misek 2003-09-22 17:49:04 EDT
Hmm, I tried the card with the latest Rawhide kernel and the problem seems to be
solved for me.

Malcolm, is the problem persisting with the latest kernel ?
Comment 9 malcolm 2003-09-23 05:42:27 EDT
I can't download it because I don't have a working network card
catch 22 - when the next beta comes out I'll download it via RH9
and give it another go 
Comment 10 Andreas Kupfer 2003-10-08 12:49:14 EDT
I have the same problem after installing the latest Beta.

When booting the Rescue-Mode from CD the network works fine.

I still have trouble after updating to 2.4.22-1.2087.nptlsmp.
Comment 11 Miloš Komarčević 2003-10-08 18:20:52 EDT
I have had the same problem with a 3c575 PCMCIA card since Severn 1 (worked ok
before), and after restarting pcmcia and network services everything is fine again.

I have also figured out that turning off the graphical boot (by editing
/etc/sysconfig/init or getting rid of the rhgb package) also gets rid of the
problem. So it might be something in rhgb? 

Latest rawhide kernel-2.4.22-1.2087.nptl doesn't fix it for me, haven't tried
2.6+rhgb yet...
Comment 12 Barry K. Nathan 2003-10-12 17:31:43 EDT
I'm having this problem with a 3CCFE575CT-D card (Dell-branded 3Com 10/100
CardBus card -- IIRC the actual network controller is a 3C905-C) and the
2087/2088 kernels. I *think* the problem did not happen with 2061 (the one that
ships with severn 2) although I'm really not sure of that. I also think it
doesn't happen if I insert the card after the system finishes booting, but again
I'm not sure of that either. I know that removing and reinserting the card
improves things if I booted with the card inserted, but I don't remember if
removing/reinserting just once is always sufficient (it's sufficient at least
part of the time though).

This card has been having problems like this on-and-off for 3 years under both
Linux and Windows. One of 3Com's driver updates seems to have fixed things for
good a year or two back under Windows. On the Linux side, things have been up
and down a bit, with the 2.6-test kernels that I ran during severn1 (with ACPI
enabled, BTW) being flawless as far as I can remember. The last time the card
was this flaky (as 2087 or 2088) under Linux was kernel 2.2.16 or so (Red Hat 7.0).

I didn't think of disabling rhgb but I'll try that now and see how things go. I
*think* it's fixed things but it's too soon to be certain...
Comment 13 Bill Nottingham 2003-10-21 16:11:52 EDT

*** This bug has been marked as a duplicate of 98767 ***
Comment 14 Red Hat Bugzilla 2006-02-21 13:57:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.