Bug 100472 - (ACPI) Reset on boot with ACPI
(ACPI) Reset on boot with ACPI
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-22 15:25 EDT by Vaclav "sHINOBI" Misek
Modified: 2013-07-02 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 11:01:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmidecode command (5.67 KB, text/plain)
2003-07-29 06:50 EDT, Vaclav "sHINOBI" Misek
no flags Details
Output from dmesg -s40000 (6.34 KB, text/plain)
2003-08-06 08:10 EDT, Vaclav "sHINOBI" Misek
no flags Details
Outputs from cat /proc/interrupts, lspci -vv, and /usr/sbin/acpidmp (51.98 KB, text/plain)
2003-08-06 08:15 EDT, Vaclav "sHINOBI" Misek
no flags Details
ACPI VT86/Award PCI interrupt patch. (12.21 KB, patch)
2003-08-21 18:27 EDT, Len Brown
no flags Details | Diff

  None (edit)
Description Vaclav "sHINOBI" Misek 2003-07-22 15:25:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After installing Severnity, I was unable to boot, computer resets right after
following messages:

ACPI: Subsystem revision 20030619
PCI: PCI BIOS revision 2.10 entry at 0xfb3d0, last bus=1
PCI: Using configuration type 1

Before ACPI system description tables appears on screen. I tried to play with
BIOS settings and when I disable ACPI support in BIOS, the linux boots up
without problems.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. Boot computer
2.
3.
    

Actual Results:  Reset before ACPI system description tables

Expected Results:  Computer should boot with ACPI enabled in BIOS.

Additional info:

I have Soltek SL-75MAV with KT133 chipset.
lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 81)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio
Controller (rev 50)
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: S3 Inc. ProSavage KM133 (rev 03)
Comment 1 Bill Nottingham 2003-07-28 15:46:42 EDT
Can you a) boot with 'acpi=off', and b) post the output of /usr/sbin/dmidecode?
Comment 2 Vaclav "sHINOBI" Misek 2003-07-29 06:50:23 EDT
Created attachment 93217 [details]
Output from dmidecode command

Yes, when acpi=off option is used as boot parameter, the system boots up even
with ACPI enabled in BIOS. Hope this helps.
Comment 3 Len Brown 2003-08-05 23:12:52 EDT
can you boot with 'linux pci=noacpi' (and no other parameters)? 
After that boot, can you get the output from 'dmesg -s40000', cat /proc/interrupts, lspci 
-vv, and /sbin/acpidmp ? 
 
Comment 4 Vaclav "sHINOBI" Misek 2003-08-06 08:10:32 EDT
Created attachment 93430 [details]
Output from dmesg -s40000

No, I can not boot even with pci=noacpi. The result is the same as booting
without acpi=off.
Comment 5 Vaclav "sHINOBI" Misek 2003-08-06 08:15:20 EDT
Created attachment 93431 [details]
Outputs from cat /proc/interrupts, lspci -vv, and /usr/sbin/acpidmp
Comment 6 Len Brown 2003-08-06 23:32:42 EDT
system has no IO-APIC, and doesn't get far enough that pci=noacpi is even 
noticed.  Maybe it resets when the ACPI interpreter is 1st enabled, or when 
digesting the PIC links...

Asus Laptop ACPI Extras version 0.24a
  Couldn't get the DSDT table header
  Error registering Asus Laptop ACPI Extras Driver 
        -0420: *** Error: Could not allocate an object descriptor

This is strange, wouldn't expect to see this, especially for acpi=off

Any chance you can capture the console output via serial line for the failure 
case?  We might learn someting by enabling CONFIG_ACPI_DEBUG
Comment 7 Len Brown 2003-08-21 18:27:51 EDT
Created attachment 93840 [details]
ACPI VT86/Award PCI interrupt patch. 

This patch has fixed the ACPI interrupt problem for similar systems.
Please try applying it to a copy of your Severn BETA1 kernel to
see if works for you too:

~/src/linux-2.4.21-20.1.2024.2.1.nptl> patch -Np1 < ./pci_link-severn.patch
patching file arch/i386/kernel/io_apic.c
patching file arch/i386/kernel/mpparse.c
patching file drivers/acpi/pci_irq.c
patching file drivers/acpi/pci_link.c
patching file include/acpi/acpi_drivers.h
Comment 8 Vaclav "sHINOBI" Misek 2003-08-24 04:27:08 EDT
Yes, after applying this patch, the omputer boots normally. Thanks and I suppose
we should close this bug. BTW Redhat should incorporate this patch to the next
Rawhide or beta kernels.
Comment 9 Vaclav "sHINOBI" Misek 2003-09-11 11:01:14 EDT
With the latest kernel (2.4.22-20.1.2024.2.36.nptl) the problem seems to be
eliminated.

Note You need to log in before you can comment on or make changes to this bug.