Bug 1004795 - glusterd.service (systemd), ensure glusterd starts before any local gluster or nfs mounts
glusterd.service (systemd), ensure glusterd starts before any local gluster o...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
:
Depends On:
Blocks: 1004796
  Show dependency treegraph
 
Reported: 2013-09-05 09:52 EDT by Kaleb KEITHLEY
Modified: 2014-04-17 07:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1004796 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:47:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2013-09-05 09:52:23 EDT
Description of problem: Users who mount gluster volumes locally, i.e. on the brick server, from /etc/fstab usually have the mount fail because glusterd isn't started early enoujgh and thus hasn't started the glusterfsds.


Version-Release number of selected component (if applicable):

All

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Also need to use _netdev as an option for glusterfs native mounts. systemd recognizes nfs and implicitly applies _netdev semantics.
Comment 1 Anand Avati 2013-09-05 10:21:26 EDT
REVIEW: http://review.gluster.org/5823 (glusterd.service (systemd), ensure glusterd starts before local mounts) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2013-09-16 11:47:45 EDT
REVIEW: http://review.gluster.org/5823 (glusterd.service (systemd), ensure glusterd starts before local mounts) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Anand Avati 2013-09-20 14:51:00 EDT
COMMIT: http://review.gluster.org/5823 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2e4064fe08e929fb4db30ae63c5cd404ab2d8b20
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Sep 5 10:14:08 2013 -0400

    glusterd.service (systemd), ensure glusterd starts before local mounts
    
    NOTICE: this patch was accepted onto the release-3.4 branch for 3.4.1,
    but this same patch for master is languishing here in review.
    
    Try (emphasis on the try) to ensure that glusterd starts, and in turn
    starts glusterfsd before init attempt to mount any gluster (or gluster
    NFS) volumes in /etc/fstab.
    
    N.B. Joe Julian says this doesn't fix the problem for him, although it
    worked for me in kvm. Lennart Poettering says it should, and we should
    file a BZ against systemd if it doesn't. See
    https://lists.fedoraproject.org/pipermail/devel/2013-July/185870.html
    
    Change-Id: I4d8061217d8301beb0da485dc63a1984a7c57c37
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    BUG: 1004795
    Reviewed-on: http://review.gluster.org/5823
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 Niels de Vos 2014-04-17 07:47:24 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.