Bug 1004796 - glusterd.service (systemd), ensure glusterd starts before any local gluster or nfs mounts
glusterd.service (systemd), ensure glusterd starts before any local gluster o...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
:
Depends On: 1004795
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 09:53 EDT by Kaleb KEITHLEY
Modified: 2014-04-17 09:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1004795
Environment:
Last Closed: 2014-04-17 09:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2013-09-05 09:53:22 EDT
+++ This bug was initially created as a clone of Bug #1004795 +++

Description of problem: Users who mount gluster volumes locally, i.e. on the brick server, from /etc/fstab usually have the mount fail because glusterd isn't started early enough and thus hasn't started the glusterfsds.


Version-Release number of selected component (if applicable):

All

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Also need to use _netdev as an option for glusterfs native mounts. systemd recognizes nfs and implicitly applies _netdev semantics.
Comment 1 Anand Avati 2013-09-05 10:32:39 EDT
REVIEW: http://review.gluster.org/5824 (glusterd.service (systemd), ensure glusterd starts early, (backport BZ 1004795)) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2013-09-09 20:18:56 EDT
COMMIT: http://review.gluster.org/5824 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit d3c5463bdc8597ce3a70fded6c80f20e900752f4
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Sep 5 10:30:25 2013 -0400

    glusterd.service (systemd), ensure glusterd starts early, (backport BZ 1004795)
    
    Try (emphasis on the try) to ensure that glusterd starts, and in turn
    starts glusterfsd before init attempt to mount any gluster (or gluster
    NFS) volumes in /etc/fstab.
    
    N.B. Joe Julian says this doesn't fix the problem for him, although it
    worked for me in kvm. Lennart Poettering says it should, and we should
    file a BZ against systemd if it doesn't. See
    https://lists.fedoraproject.org/pipermail/devel/2013-July/185870.html
    
    Change-Id: I6ac329b5130ba5615df570cf151e70d3618a8a63
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    BUG: 1004796
    Reviewed-on: http://review.gluster.org/5824
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 09:14:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.