Bug 1004874 - TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
Status: CLOSED DUPLICATE of bug 1005506
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f7d5e4d75cce83bc69d25ece0f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 12:00 EDT by Martin
Modified: 2014-09-14 20:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 10:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (643.58 KB, text/plain)
2013-09-05 12:00 EDT, Martin
no flags Details
File: anaconda.log (10.11 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: environ (500 bytes, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: lsblk_output (1.17 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: nmcli_dev_list (4.71 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: program.log (20.26 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: storage.log (49.93 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: syslog (60.77 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: ifcfg.log (398 bytes, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details
File: packaging.log (353.98 KB, text/plain)
2013-09-05 12:01 EDT, Martin
no flags Details

  None (edit)
Description Martin 2013-09-05 12:00:50 EDT
Description of problem:
1. select "LVM thin provisioning" option
2. enable full disk encryption
3. select manual partitioning mode
4. click on "create partitions automatically" 

Version-Release number of selected component:
anaconda-20.10-1

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2615, in vgSpaceUsed
    + self.logSize + self.metaDataSize)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2847, in vgSpaceUsed
    space = super(LVMThinPoolDevice, self).vgSpaceUsed
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2409, in <genexpr>
    used = sum(lv.vgSpaceUsed for lv in self.lvs) + self.snapshotSpace
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2409, in freeSpace
    used = sum(lv.vgSpaceUsed for lv in self.lvs) + self.snapshotSpace
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2296, in _addLogVol
    lv.size > self.freeSpace:
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2564, in __init__
    self.parents[0]._addLogVol(self)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1144, in newLV
    return device_class(name, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 282, in _scheduleVolumes
    dev = new_volume(**kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 321, in doAutoPartition
    _scheduleVolumes(storage, devs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2497, in _do_autopart
    doAutoPartition(self.__storage, self.data)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2530, in on_create_clicked
    self._do_autopart()
TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/20-Alpha-TC4/Fedora/x86_64/iso/Fedora-20-Alpha-TC4-x86_64-DVD.iso initrd=F20/Alpha-TC4/x86_64/initrd.img BOOT_IMAGE=F20/Alpha-TC4/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC4
Comment 1 Martin 2013-09-05 12:00:58 EDT
Created attachment 794330 [details]
File: anaconda-tb
Comment 2 Martin 2013-09-05 12:01:02 EDT
Created attachment 794332 [details]
File: anaconda.log
Comment 3 Martin 2013-09-05 12:01:06 EDT
Created attachment 794334 [details]
File: environ
Comment 4 Martin 2013-09-05 12:01:11 EDT
Created attachment 794337 [details]
File: lsblk_output
Comment 5 Martin 2013-09-05 12:01:15 EDT
Created attachment 794339 [details]
File: nmcli_dev_list
Comment 6 Martin 2013-09-05 12:01:20 EDT
Created attachment 794341 [details]
File: os_info
Comment 7 Martin 2013-09-05 12:01:25 EDT
Created attachment 794343 [details]
File: program.log
Comment 8 Martin 2013-09-05 12:01:32 EDT
Created attachment 794344 [details]
File: storage.log
Comment 9 Martin 2013-09-05 12:01:36 EDT
Created attachment 794346 [details]
File: syslog
Comment 10 Martin 2013-09-05 12:01:40 EDT
Created attachment 794347 [details]
File: ifcfg.log
Comment 11 Martin 2013-09-05 12:01:46 EDT
Created attachment 794348 [details]
File: packaging.log
Comment 12 Martin 2013-09-05 12:07:13 EDT
I can reproduce this also without steps 2-4.
Comment 13 Reartes Guillermo 2013-09-07 14:47:40 EDT
I selected lvm thin provisioning, but instead of automatic partitioning i did custom partititioning, manually deleting existing partitions prior to use the guided partitioning, at which point anaconda crashed. 

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 14 Reartes Guillermo 2013-09-07 14:49:52 EDT
Bug 1005506 might be a dup of this one.
Comment 15 William Brown 2013-09-12 09:55:35 EDT
Using LVM thin provision, then manually setup partitions. Clicking the + to automatically add caused this issue.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
release:        Cannot get release name.
version:        20-Alpha
Comment 16 David Shea 2013-09-12 10:19:45 EDT

*** This bug has been marked as a duplicate of bug 1005506 ***

Note You need to log in before you can comment on or make changes to this bug.