Bug 1005506 - TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:3261f9ac6dd9a246e837f04bffd...
:
: 1004874 1010489 (view as bug list)
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-07 14:37 EDT by Reartes Guillermo
Modified: 2014-09-13 14:56 EDT (History)
16 users (show)

See Also:
Fixed In Version: python-blivet-0.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 18:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (708.56 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (8.95 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: environ (441 bytes, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: lsblk_output (1.37 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: nmcli_dev_list (7.68 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: program.log (32.91 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: storage.log (92.72 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: syslog (73.97 KB, text/plain)
2013-09-07 14:37 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (1.14 KB, text/plain)
2013-09-07 14:38 EDT, Reartes Guillermo
no flags Details
File: packaging.log (354.38 KB, text/plain)
2013-09-07 14:38 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-09-07 14:37:12 EDT
Description of problem:
I setup a hostname, then went directly to storage and selected "lvm thin provisioning" and set it do delete existing partitions, then anaconda crashes.

Only network and then storage spokes were used.

Version-Release number of selected component:
anaconda-20.10-1

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2615, in vgSpaceUsed
    + self.logSize + self.metaDataSize)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2847, in vgSpaceUsed
    space = super(LVMThinPoolDevice, self).vgSpaceUsed
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2409, in <genexpr>
    used = sum(lv.vgSpaceUsed for lv in self.lvs) + self.snapshotSpace
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2409, in freeSpace
    used = sum(lv.vgSpaceUsed for lv in self.lvs) + self.snapshotSpace
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2296, in _addLogVol
    lv.size > self.freeSpace:
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2564, in __init__
    self.parents[0]._addLogVol(self)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1144, in newLV
    return device_class(name, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 282, in _scheduleVolumes
    dev = new_volume(**kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 321, in doAutoPartition
    _scheduleVolumes(storage, devs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 244, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1677, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 419, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC4
Comment 1 Reartes Guillermo 2013-09-07 14:37:23 EDT
Created attachment 795174 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2013-09-07 14:37:28 EDT
Created attachment 795175 [details]
File: anaconda.log
Comment 3 Reartes Guillermo 2013-09-07 14:37:32 EDT
Created attachment 795176 [details]
File: environ
Comment 4 Reartes Guillermo 2013-09-07 14:37:36 EDT
Created attachment 795177 [details]
File: lsblk_output
Comment 5 Reartes Guillermo 2013-09-07 14:37:41 EDT
Created attachment 795178 [details]
File: nmcli_dev_list
Comment 6 Reartes Guillermo 2013-09-07 14:37:45 EDT
Created attachment 795179 [details]
File: os_info
Comment 7 Reartes Guillermo 2013-09-07 14:37:49 EDT
Created attachment 795180 [details]
File: program.log
Comment 8 Reartes Guillermo 2013-09-07 14:37:54 EDT
Created attachment 795181 [details]
File: storage.log
Comment 9 Reartes Guillermo 2013-09-07 14:37:58 EDT
Created attachment 795182 [details]
File: syslog
Comment 10 Reartes Guillermo 2013-09-07 14:38:02 EDT
Created attachment 795183 [details]
File: ifcfg.log
Comment 11 Reartes Guillermo 2013-09-07 14:38:10 EDT
Created attachment 795184 [details]
File: packaging.log
Comment 12 David Shea 2013-09-12 10:19:45 EDT
*** Bug 1004874 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Blocker Bugs Application 2013-09-17 10:53:00 EDT
Proposed as a Blocker for 20-beta by Fedora user martix using the blocker tracking app because:

 Guided partitioning:
"Complete an installation using any combination of disk configuration options it allows the user to select."

Read comment #12: https://bugzilla.redhat.com/show_bug.cgi?id=1004874#c12
Comment 14 David Shea 2013-09-21 08:31:55 EDT
*** Bug 1010489 has been marked as a duplicate of this bug. ***
Comment 15 Stephen Gallagher 2013-09-24 13:12:37 EDT
I attempted to install a Fedora 20 Alpha VM, using the x86_64 Alpha DVD ISO as the install media. The VM was KVM on a Fedora 19 x86_64 host with 1024MB RAM and 2 processors.

I selected LVM Thin Provisioning as the filesystem type and was met with the error this BZ reports. I also tried previously to use LVM Thin Provisioning with encryption, which also failed.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1
product:        Fedora
reason:         TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
release:        Cannot get release name.
version:        20-Alpha
Comment 16 Renich Bon Ciric 2013-09-24 16:45:48 EDT
I tried installing Fedora Alpha via BFO.

The Guest has 8 GB of HDD and I tried a minimal install using Btrfs. It didn't work; it claimed I lacked ~940 MB of HDD space; which amounted to the full installation.

Then, I switched to LVM Thin Provisioned and this happened.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   repo=http://download.fedoraproject.org/pub/fedora/linux/development/20/x86_64/os/ initrd=http://download.fedoraproject.org/pub/fedora/linux/releases/test/20-Alpha/Fedora/x86_64/os/images/pxeboot/initrd.img BOOT_IMAGE=http://download.fedoraproject.org/pub/fedora/linux/releases/test/20-Alpha/Fedora/x86_64/os/images/pxeboot/vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1
product:        Fedora
reason:         TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
release:        Cannot get release name.
version:        20
Comment 17 Mike Ruckman 2013-09-25 13:46:49 EDT
Discussed during 2013-09-25 Blocker Review Meeting [1] - AcceptedBlocker - Violates the following F20 beta release criterion: "Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning
Comment 18 Adam Williamson 2013-10-01 18:33:24 EDT
blivet 0.22 went stable already; closing for now, re-open if it's still valid with Beta TC1.

Note You need to log in before you can comment on or make changes to this bug.