Bug 100492 - KWin Bluecurve glitches (with screenshots!)
KWin Bluecurve glitches (with screenshots!)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-artwork (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-22 17:53 EDT by Peter Backlund
Modified: 2007-04-18 12:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 05:35:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kwin Bluecurve bug. (17.20 KB, image/png)
2003-07-22 17:54 EDT, Peter Backlund
no flags Details
Kwin BC bug. (12.23 KB, image/png)
2003-07-22 17:54 EDT, Peter Backlund
no flags Details
Kwin BC bug. (7.39 KB, image/png)
2003-07-22 17:54 EDT, Peter Backlund
no flags Details
Highlight and button size (1.07 KB, patch)
2003-08-15 12:01 EDT, Peter Backlund
no flags Details | Diff

  None (edit)
Description Peter Backlund 2003-07-22 17:53:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
The minimize/maximize/close buttons in kwin aren't properly drawn on smaller windows, especially when the button setup differs from standard (min/max/close).



Version-Release number of selected component (if applicable):
0.77-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Any kwin window with BC decoration, as described above. KsCD is a good example.
2. 
3.
    

Actual Results:  Not properly drawn window decoration.

Expected Results:  Properly drawn window decoration.

Additional info:
Comment 1 Peter Backlund 2003-07-22 17:54:04 EDT
Created attachment 93062 [details]
Kwin Bluecurve bug.
Comment 2 Peter Backlund 2003-07-22 17:54:36 EDT
Created attachment 93063 [details]
Kwin BC bug.
Comment 3 Peter Backlund 2003-07-22 17:54:59 EDT
Created attachment 93064 [details]
Kwin BC bug.
Comment 4 Alexander Larsson 2003-08-06 04:53:32 EDT
than or harald, could one of you look into this? You seem to have been doing
most of the kwin theme work.
Comment 5 Harald Hoyer 2003-08-13 09:26:26 EDT
fixed in CVS
Comment 6 Harald Hoyer 2003-08-14 08:34:07 EDT
please build a new package..
Comment 7 Peter Backlund 2003-08-15 12:01:05 EDT
Created attachment 93664 [details]
Highlight and button size

Patch against redhatclient.cpp from CVS 2003-08-15. Adds highlighting, as
requested in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=102458 and
fixes the leftmost button on the right being on pixel too narrow.
Comment 8 Alexander Larsson 2003-08-18 03:39:28 EDT
see comment in bug 102458
Comment 9 Alexander Larsson 2003-09-04 06:59:24 EDT
Peter, are all your patches in the latest redhat-artwork? I'm sort of losing
track of them...
Comment 10 Harald Hoyer 2003-09-04 07:08:15 EDT
yes
Comment 11 Peter Backlund 2004-11-26 14:48:53 EST
This has been fixed for a while, I can't reproduce it anymore. Go
ahead and close.

Note You need to log in before you can comment on or make changes to this bug.