Bug 1004925 - ValueError: ('invalid size specification', 'MB')
ValueError: ('invalid size specification', 'MB')
Status: CLOSED DUPLICATE of bug 1004903
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:c3ac293ce29101830a644652690...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 14:40 EDT by Ryan Lerch
Modified: 2013-09-05 14:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 14:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (806.64 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: anaconda.log (25.95 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: environ (441 bytes, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: lsblk_output (1.91 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: nmcli_dev_list (11.14 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: program.log (82.89 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: storage.log (147.41 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: syslog (97.56 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: ifcfg.log (828 bytes, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details
File: packaging.log (355.47 KB, text/plain)
2013-09-05 14:40 EDT, Ryan Lerch
no flags Details

  None (edit)
Description Ryan Lerch 2013-09-05 14:40:07 EDT
Description of problem:
Once in custom partitioning, I blanked out the size value for the root partition (i was using normal partitoning, not LVM), and clicked update settings. 


Version-Release number of selected component:
anaconda-20.10-1

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 156, in size_from_entry
    size = Size(spec=size_text)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1137, in _save_right_side
    size = size_from_entry(self._sizeEntry)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2788, in on_apply_clicked
    self._save_right_side(self._current_selector)
ValueError: ('invalid size specification', 'MB')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC4
Comment 1 Ryan Lerch 2013-09-05 14:40:14 EDT
Created attachment 794433 [details]
File: anaconda-tb
Comment 2 Ryan Lerch 2013-09-05 14:40:19 EDT
Created attachment 794434 [details]
File: anaconda.log
Comment 3 Ryan Lerch 2013-09-05 14:40:22 EDT
Created attachment 794435 [details]
File: environ
Comment 4 Ryan Lerch 2013-09-05 14:40:25 EDT
Created attachment 794436 [details]
File: lsblk_output
Comment 5 Ryan Lerch 2013-09-05 14:40:29 EDT
Created attachment 794437 [details]
File: nmcli_dev_list
Comment 6 Ryan Lerch 2013-09-05 14:40:34 EDT
Created attachment 794438 [details]
File: os_info
Comment 7 Ryan Lerch 2013-09-05 14:40:38 EDT
Created attachment 794439 [details]
File: program.log
Comment 8 Ryan Lerch 2013-09-05 14:40:42 EDT
Created attachment 794440 [details]
File: storage.log
Comment 9 Ryan Lerch 2013-09-05 14:40:46 EDT
Created attachment 794441 [details]
File: syslog
Comment 10 Ryan Lerch 2013-09-05 14:40:50 EDT
Created attachment 794442 [details]
File: ifcfg.log
Comment 11 Ryan Lerch 2013-09-05 14:40:53 EDT
Created attachment 794443 [details]
File: packaging.log
Comment 12 David Shea 2013-09-05 14:44:59 EDT

*** This bug has been marked as a duplicate of bug 1004903 ***

Note You need to log in before you can comment on or make changes to this bug.