Bug 1004903 - ValueError: ('invalid size specification', 'MB')
ValueError: ('invalid size specification', 'MB')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:c8d5812822970b5edcd6be2f92d...
:
: 1004925 1010494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 13:34 EDT by Martin
Modified: 2014-09-14 20:04 EDT (History)
15 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (92.59 KB, text/plain)
2013-09-05 13:34 EDT, Martin
no flags Details
File: environ (500 bytes, text/plain)
2013-09-05 13:34 EDT, Martin
no flags Details
File: lsblk_output (2.12 KB, text/plain)
2013-09-05 13:34 EDT, Martin
no flags Details
File: nmcli_dev_list (17.57 KB, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: program.log (71.77 KB, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: storage.log (394.69 KB, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: syslog (94.03 KB, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: ifcfg.log (394 bytes, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: packaging.log (347.95 KB, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
File: anaconda-tb (1.11 MB, text/plain)
2013-09-05 13:35 EDT, Martin
no flags Details
anaconda-tb-* (1.26 MB, text/plain)
2013-09-07 14:32 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Martin 2013-09-05 13:34:41 EDT
Version-Release number of selected component:
anaconda-20.10-1

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 156, in size_from_entry
    size = Size(spec=size_text)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 282, in on_add_confirm_clicked
    self.size = size_from_entry(self.builder.get_object("addSizeEntry"))
ValueError: ('invalid size specification', 'MB')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/20-Alpha-TC4/Fedora/x86_64/iso/Fedora-20-Alpha-TC4-x86_64-DVD.iso initrd=F20/Alpha-TC4/x86_64/initrd.img BOOT_IMAGE=F20/Alpha-TC4/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC4
Comment 1 Martin 2013-09-05 13:34:48 EDT
Created attachment 794391 [details]
File: anaconda.log
Comment 2 Martin 2013-09-05 13:34:53 EDT
Created attachment 794392 [details]
File: environ
Comment 3 Martin 2013-09-05 13:34:57 EDT
Created attachment 794393 [details]
File: lsblk_output
Comment 4 Martin 2013-09-05 13:35:02 EDT
Created attachment 794394 [details]
File: nmcli_dev_list
Comment 5 Martin 2013-09-05 13:35:10 EDT
Created attachment 794395 [details]
File: os_info
Comment 6 Martin 2013-09-05 13:35:15 EDT
Created attachment 794396 [details]
File: program.log
Comment 7 Martin 2013-09-05 13:35:22 EDT
Created attachment 794397 [details]
File: storage.log
Comment 8 Martin 2013-09-05 13:35:30 EDT
Created attachment 794398 [details]
File: syslog
Comment 9 Martin 2013-09-05 13:35:34 EDT
Created attachment 794399 [details]
File: ifcfg.log
Comment 10 Martin 2013-09-05 13:35:40 EDT
Created attachment 794400 [details]
File: packaging.log
Comment 11 Martin 2013-09-05 13:35:49 EDT
Created attachment 794401 [details]
File: anaconda-tb
Comment 12 David Shea 2013-09-05 14:44:59 EDT
*** Bug 1004925 has been marked as a duplicate of this bug. ***
Comment 13 Reartes Guillermo 2013-09-07 14:28:04 EDT
wen to custom partitioning, deletet all exept /boot (because i requiered 300mb more for kde and / was too small --swap was too big--).

after deleting, i recreated swap (smaller) 512mb. then created / without a size, anaconda crashed.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         ValueError: ('invalid size specification', 'MB')
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 14 Reartes Guillermo 2013-09-07 14:32:37 EDT
Created attachment 795173 [details]
anaconda-tb-*
Comment 15 L.L.Robinson 2013-09-07 16:04:03 EDT
Tried to set a partition size to no value and update settings, Previously this would set the size to the maximum available

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         ValueError: ('invalid size specification', 'MB')
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 16 Lukas Brabec 2013-09-13 04:00:21 EDT
Just trying disc partitioning (/boot ext2, / lvm ext4, /home), error occured after /home mount point addition with no size set.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         ValueError: ('invalid size specification', 'MB')
release:        Cannot get release name.
version:        20-Alpha
Comment 17 Ferdinand Galko 2013-09-13 14:03:53 EDT
Anaconda in VMware Player 6 virtual machine, netinstall iso

Installation options 
1. Option: I want to review/modify my disk partitions before continuing
2. Partition scheme: Standard Partition
3. Add a new mountpoint
    Mount point: /
    Desired Capacity: 9g
4. Add a new mountpoint
    Mount point: swap
    Desired Capacity: 1g
5. Add a new mountpoint
    Mount point: /home
    Desired Capacity: "I left this option empty, because I wanted use rest of 20GB disk"
6. There occured an error after using <Add mount point> button.

Note:
This way of partitionig is working in Anaconda in Fedora 19.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         ValueError: ('invalid size specification', 'MB')
release:        Cannot get release name.
version:        20-Alpha
Comment 18 Fedora Update System 2013-09-16 13:45:50 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 19 Fedora Update System 2013-09-18 22:38:17 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 David Shea 2013-09-23 09:40:18 EDT
*** Bug 1010494 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.