Bug 100512 - Apache configuration tool won't load; can't find xslt module
Apache configuration tool won't load; can't find xslt module
Status: CLOSED DUPLICATE of bug 99490
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 20:27 EDT by Jonathan Smith
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Smith 2003-07-22 20:27:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030718
Mozilla Firebird/0.6

Description of problem:
When I try to lanch the RedHat Apache configuration tool from the gnome menu, I
just get an hourglass for a few seconds then it does nothing. When launching
from a command-line shell I get the following error: 
Traceback (most recent call last):
  File "/usr/share/redhat-config-httpd/ApacheConf.py", line 50, in ?
    import ApacheGizmo
  File "/usr/share/redhat-config-httpd/ApacheGizmo.py", line 36, in ?
    import ApacheBase
  File "/usr/share/redhat-config-httpd/ApacheBase.py", line 9, in ?
    from xml.xslt.Processor import Processor
ImportError: No module named xslt.Processor

The program should just load, but instead this happens. It happens every time I
try to load it.

Version-Release number of selected component (if applicable):
1.1.0-1.1

How reproducible:
Always

Steps to Reproduce:
1. Type "redhat-config-httpd" in the command line
2.
3.
    

Actual Results:  Got error shown in description

Expected Results:  Program loads

Additional info:
Comment 1 Need Real Name 2003-07-24 03:47:34 EDT
The problem appears to be in /usr/share/redhat-config-httpd/ApacheBase.py
it references xml.xslt.Processor

However the file is /Ft/Xml/Xslt/Processor.py, so if you change this to 

Ft.Xml.Xslt.Processor it works.

Looks like a problem with the path and case.
Comment 2 Jonathan Smith 2003-07-24 18:25:50 EDT
I changed the /usr/share/redhat-config-httpd/ApacheBase.py import line to
Ft.Xml.Xslt.Processor, as instructed by mike@redtux.demon.co.uk, but now I get a
whole slew of errors in the command line, and clicking the ok button pops up
with the message "Are you sure you want to exit and save changes." I click yes,
then nothing happens. The errors seem to complain of missing attributes of the
Processor file:

(ApacheConf.py:5288): Gnome-CRITICAL **: file gnome-program.c: line 738 (gnome_
program_get_app_id): assertion `program != NULL' failed
 
(ApacheConf.py:5288): Gnome-CRITICAL **: file gnome-program.c: line 738 (gnome_
program_get_app_id): assertion `program != NULL' failed
 
(ApacheConf.py:5288): Gnome-CRITICAL **: file gnome-program.c: line 738 (gnome_
program_get_app_id): assertion `program != NULL' failed
Traceback (most recent call last):
  File "/usr/share/redhat-config-httpd/ApacheConf.py", line 273, in on_main_ok_
button_clicked
    if not control.write():
  File "/usr/share/redhat-config-httpd/ApacheControl.py", line 63, in write
    return stack.apache.write(force)
  File "/usr/share/redhat-config-httpd/ApacheGizmo.py", line 771, in write
    return ApacheBase.write (force)
  File "/usr/share/redhat-config-httpd/ApacheBase.py", line 4340, in write
    processor.appendStylesheetUri ('/usr/share/redhat-config-httpd/httpd.conf.x sl')
AttributeError: Processor instance has no attribute 'appendStylesheetUri'
Traceback (most recent call last):
  File "/usr/share/redhat-config-httpd/ApacheConf.py", line 273, in on_main_ok_
button_clicked
    if not control.write():
  File "/usr/share/redhat-config-httpd/ApacheControl.py", line 63, in write
    return stack.apache.write(force)
  File "/usr/share/redhat-config-httpd/ApacheGizmo.py", line 771, in write
    return ApacheBase.write (force)
  File "/usr/share/redhat-config-httpd/ApacheBase.py", line 4340, in write
    processor.appendStylesheetUri ('/usr/share/redhat-config-httpd/httpd.conf.x sl')
AttributeError: Processor instance has no attribute 'appendStylesheetUri'
Comment 3 Bill Nottingham 2003-07-28 15:52:21 EDT

*** This bug has been marked as a duplicate of 99490 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:57:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.