Bug 99490 - redhat-config-httpd doesnt run in Severn
redhat-config-httpd doesnt run in Severn
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 100512 105828 108490 109481 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-21 07:14 EDT by Richard Allen
Modified: 2015-03-04 20:12 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-29 08:29:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix line 9 in ApacheBase.py script (Ft.Xml.Xslt.Processor) (319 bytes, patch)
2003-07-29 22:58 EDT, Jesus Ortega (a.k.a Nitebirdz)
no flags Details | Diff

  None (edit)
Description Richard Allen 2003-07-21 07:14:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030702

Description of problem:
[root@localhost root]# redhat-config-httpd 
Traceback (most recent call last):
  File "/usr/share/redhat-config-httpd/ApacheConf.py", line 50, in ?
    import ApacheGizmo
  File "/usr/share/redhat-config-httpd/ApacheGizmo.py", line 36, in ?
    import ApacheBase
  File "/usr/share/redhat-config-httpd/ApacheBase.py", line 9, in ?
    from xml.xslt.Processor import Processor
ImportError: No module named xslt.Processor



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot severn
2. Run the program
3.
    

Additional info:
Comment 1 Bill Nottingham 2003-07-28 15:52:24 EDT
*** Bug 100512 has been marked as a duplicate of this bug. ***
Comment 2 Jesus Ortega (a.k.a Nitebirdz) 2003-07-29 22:58:56 EDT
Created attachment 93249 [details]
Fix line 9 in ApacheBase.py script (Ft.Xml.Xslt.Processor)
Comment 3 Jesus Ortega (a.k.a Nitebirdz) 2003-07-29 23:08:09 EDT
I manage to reproduce the problem by running the command using the absolute path:

# /usr/share/redhat-config-httpd/redhat-config-httpd
Traceback (most recent call last):
  File "/usr/share/redhat-config-httpd/ApacheConf.py", line 50, in ?
    import ApacheGizmo
  File "ApacheGizmo.py", line 36, in ?
    import ApacheBase
  File "/usr/share/redhat-config-httpd/ApacheBase.py", line 9, in ?
    from xml.xslt.Processor import Processor
ImportError: No module named xslt.Processor


Yet, fixing line 9 in the "ApacheBase.py" file the problem appears to go away
(see unified diff attached to the bug report):
from Ft.Xml.Xslt.Processor import Processor

Yet, the problem is still there when running the command from the default path
although it shows in a different way:
# /usr/bin/redhat-config-httpd
(GTK window with "Unknown error" message)

# which redhat-config-httpd | xargs ls -l
lrwxrwxrwx    1 root     root           13 Jul 24 21:06
/usr/bin/redhat-config-httpd -> consolehelper

I performed a trace of the 'redhat-config-httpd', and came across something that
may be of some help (I'm no expert):
(...)
29729      0.000414 open("/etc/security/console.apps/redhat-config-httpd",
O_RDWR) = -1 ENOENT (No such file or directory)
29729      0.000253 open("/etc/security/console.apps/redhat-config-httpd",
O_RDONLY) = -1 ENOENT (No such file or directory)
(...)

# ls -l /etc/security/console.apps/redhat-config-httpd
lrwxrwxrwx    1 root     root           37 Oct 19  2002
/etc/security/console.apps/redhat-config-httpd ->
/etc/security/console.apps/apacheconf

(The symlink is broken in Severn)
Comment 4 Dave Habben 2003-10-08 11:43:34 EDT
Looks like a duplicate of bug 105828 one of these two should be closed.
Comment 5 Mario 2003-10-16 15:28:38 EDT
This problem is present in Fedore Beta 2 and 3 since the same package version is
used:

redhat-config-httpd-1.1.0-3

Comment 6 Phil Knirsch 2003-10-17 04:30:29 EDT
Will be fixed among with a few other things real soon with a new version in Fedora.

Thanks,

Read ya, Phil
Comment 7 Bill Nottingham 2003-10-21 16:45:29 EDT
*** Bug 105828 has been marked as a duplicate of this bug. ***
Comment 8 Phil Knirsch 2003-10-29 08:29:06 EST
Fixed in redhat-config-httpd-1.1.0-5 and later.

Read ya, Phil
Comment 9 Bill Nottingham 2003-10-30 00:13:05 EST
*** Bug 108490 has been marked as a duplicate of this bug. ***
Comment 10 Phil Knirsch 2003-11-08 16:58:36 EST
*** Bug 109481 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.