This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 100514 - Can't load dvorak keyboard layout
Can't load dvorak keyboard layout
Status: CLOSED DUPLICATE of bug 90562
Product: Red Hat Linux Beta
Classification: Retired
Component: kbd (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 20:38 EDT by Jonathan Smith
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Smith 2003-07-22 20:38:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030718
Mozilla Firebird/0.6

Description of problem:
The Dvorak keyboard layout works fine in X, but not in the console (via
/sbin/init 3), and "loadkeys dvorak" always fails. I get the following error:

Loading //lib/kbd/keymaps/i386/dvorak
input in flex scanner failed

This is easily fixable by editing /etc/sysconfig/keyboard and changing KEYTABLE
to /lib/kbd/keymaps/i386/dvorak/dvorak.map.gz, but it is just very annoying, and
this should not be a problem, and should be fixed. Using redhat-config-keyboard
resets KEYTABLE to dvorak and I get the problem again. 

Also, I noticed that the /lib/kbd/keymaps/i386/dvorak directory contains ANSI
Dvorak and right-handed and left-handed Dvorak. Although I don't personally use
them, they could be easily added to redhat-config-keyboard and the initial
installation program. 

Version-Release number of selected component (if applicable):
1.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. Type "loadkeys dvorak"
2.
3.
    

Actual Results:  showed this error:

Loading //lib/kbd/keymaps/i386/dvorak
input in flex scanner failed

Expected Results:  just loaded the keymap

Additional info:

I did not have this problem in Red Hat 8, but I did have it in 9.
Comment 1 Brent Fox 2003-07-22 22:47:09 EDT
The console keymaps come from the kbd package.  Changing components.
Comment 3 Eido Inoue 2003-07-25 12:55:58 EDT

*** This bug has been marked as a duplicate of 90562 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:57:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.