This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 100522 - (ACPI) acpi code breaks e100 and eepro100 drivers
(ACPI) acpi code breaks e100 and eepro100 drivers
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-23 00:25 EDT by Nathan G. Grennan
Modified: 2015-01-04 17:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-28 11:25:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output (5.19 KB, text/plain)
2003-07-29 11:48 EDT, Nathan G. Grennan
no flags Details
acpidmp output (67.35 KB, text/plain)
2003-07-29 11:48 EDT, Nathan G. Grennan
no flags Details
acpidmp output (68.66 KB, text/plain)
2003-07-29 20:16 EDT, Ethan Bonick
no flags Details
dmidencode output (5.19 KB, text/plain)
2003-07-29 20:17 EDT, Ethan Bonick
no flags Details
ACPI VT86/Award PCI interrupt patch. (12.21 KB, patch)
2003-08-21 18:29 EDT, Len Brown
no flags Details | Diff

  None (edit)
Description Nathan G. Grennan 2003-07-23 00:25:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030720

Description of problem:
I loaded Serven on my workstation at work. After booting up I found though there
were no errors and the ip information was set correctly my network didn't work.
I tried didn't cables, a crossover cable to another computer, e100 and eepro100
drivers. Finally I added acpi=off apci=off to the kernel during boot. Suddenly
the network was working again. Next I tried just apci=off, and it didn't work
again. Then I tried acpi=off by itself and it worked.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. Load Serven
2. Install a Intel 10/100 card
3. Configure network with netconfig or neat
4. modprobe e100 or modprobe eepro100
5. service network start

    

Actual Results:  Everything looks good, but networking doesn't work

Expected Results:  Everything looks good, and networking works

Additional info:
Comment 1 Bill Nottingham 2003-07-28 16:08:17 EDT
Can you post the output of 'dmidecode' for your system?
Comment 2 Michael K. Johnson 2003-07-29 10:57:40 EDT
That's /usr/sbin/dmidecode -- run as root.
Please also post the output of /usr/sbin/acpidmp
Comment 3 Nathan G. Grennan 2003-07-29 11:48:28 EDT
Created attachment 93223 [details]
dmidecode output
Comment 4 Nathan G. Grennan 2003-07-29 11:48:59 EDT
Created attachment 93224 [details]
acpidmp output
Comment 5 Nathan G. Grennan 2003-07-29 11:49:44 EDT
I also tried acpi=nopci while I was at it and it didn't help.
Comment 6 Ethan Bonick 2003-07-29 20:16:14 EDT
Created attachment 93243 [details]
acpidmp output
Comment 7 Ethan Bonick 2003-07-29 20:17:09 EDT
Created attachment 93244 [details]
dmidencode output

realtek 8139 module
Comment 8 Ethan Bonick 2003-07-29 20:17:38 EDT
Comment on attachment 93243 [details]
acpidmp output

realtek 8139
Comment 9 Len Brown 2003-07-31 00:58:42 EDT
I don't have Gigabyte/AMD/Award or Abit/AMD/Phoenix systems handy,
but severn on my Intel/Intel/AMI boxes seem to talk to e100 just fine.

Is it possible to get the dmesg, /proc/interrupts, and ifconfig output
for both the success and failure cases?
Comment 10 Len Brown 2003-08-21 18:29:34 EDT
Created attachment 93841 [details]
ACPI VT86/Award PCI interrupt patch. 


This patch has fixed the ACPI interrupt problem for similar systems.
Please try applying it to a copy of your Severn BETA1 kernel to
see if works for you too:

~/src/linux-2.4.21-20.1.2024.2.1.nptl> patch -Np1 < ./pci_link-severn.patch
patching file arch/i386/kernel/io_apic.c
patching file arch/i386/kernel/mpparse.c
patching file drivers/acpi/pci_irq.c
patching file drivers/acpi/pci_link.c
patching file include/acpi/acpi_drivers.h
Comment 11 Michael K. Johnson 2003-10-21 16:12:51 EDT
Dave, please take a look at this patch, thanks.
Comment 12 Dave Jones 2003-10-21 16:51:44 EDT
AFAICT, we have an improved variant of this patch already merged since test2
Comment 13 Dave Jones 2003-10-28 11:25:15 EST
Personally, I'm convinced this is fixed. I can't repeat any problems with or
without acpi=on using e100 or e1000 on several boxes.

Note You need to log in before you can comment on or make changes to this bug.