Bug 1005249 - netinst with text mode doesn't allow to install GNOME (broken mirror?)
netinst with text mode doesn't allow to install GNOME (broken mirror?)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 10:02 EDT by Kamil Páral
Modified: 2014-04-07 11:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-07 11:01:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (11.89 KB, image/png)
2013-09-06 10:02 EDT, Kamil Páral
no flags Details
anaconda.log (3.84 KB, text/plain)
2013-09-06 10:03 EDT, Kamil Páral
no flags Details
anaconda-yum.conf (351 bytes, text/plain)
2013-09-06 10:03 EDT, Kamil Páral
no flags Details
ifcfg.log (567 bytes, text/plain)
2013-09-06 10:03 EDT, Kamil Páral
no flags Details
packaging.log (195.18 KB, text/plain)
2013-09-06 10:03 EDT, Kamil Páral
no flags Details
program.log (19.39 KB, text/plain)
2013-09-06 10:04 EDT, Kamil Páral
no flags Details
storage.log (62.09 KB, text/plain)
2013-09-06 10:04 EDT, Kamil Páral
no flags Details
syslog (64.52 KB, text/plain)
2013-09-06 10:04 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-09-06 10:02:43 EDT
Created attachment 794756 [details]
screenshot

Description of problem:
If I boot netinst and don't touch anything at all, just refresh the screen, the metadata are downloaded from the closest mirror and than I see "[!] Software selection (Source changed - please verify)".

This is a recent change, it didn't use to force user to verify selection, if installation source wasn't changed (i.e. was on default).

Version-Release number of selected component (if applicable):
F20 Alpha TC4
anaconda 20.10

How reproducible:
always

Steps to Reproduce:
1. boot netinst
2. refresh screen, don't touch installation source
3. see "please verify" in software selection

Actual results:
user has to verify the default

Expected results:
user doesn't have to verify the default

Additional info:
Comment 1 Kamil Páral 2013-09-06 10:03:40 EDT
Created attachment 794757 [details]
anaconda.log
Comment 2 Kamil Páral 2013-09-06 10:03:45 EDT
Created attachment 794758 [details]
anaconda-yum.conf
Comment 3 Kamil Páral 2013-09-06 10:03:51 EDT
Created attachment 794759 [details]
ifcfg.log
Comment 4 Kamil Páral 2013-09-06 10:03:58 EDT
Created attachment 794760 [details]
packaging.log
Comment 5 Kamil Páral 2013-09-06 10:04:04 EDT
Created attachment 794761 [details]
program.log
Comment 6 Kamil Páral 2013-09-06 10:04:12 EDT
Created attachment 794762 [details]
storage.log
Comment 7 Kamil Páral 2013-09-06 10:04:19 EDT
Created attachment 794763 [details]
syslog
Comment 8 Kamil Páral 2013-09-06 10:11:40 EDT
Actually, this is even funnier. I can't confirm that I want to install GNOME. If I enter the dialog and hit "c", I still see "please verify" error. If I pick KDE, everything seems OK. If I enter it again and change to GNOME, I again see "please verify" error. During screen refreshes I see a lot of yum errors.

This seems to be violating:
"When using the dedicated installer images, the installer must be able to use either HTTP or FTP repositories (or both) as package sources. The network install image must default to a valid publicly-accessible package source. "
https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Remote_package_sources

Proposing as a blocker.
Comment 9 Kamil Páral 2013-09-06 10:16:47 EDT
The same can be reproduced with DVD text mode. Just try to switch to Closest Mirror and you'll see the same behavior.

Also, the indicator next to Installation source if _very_ weird. Sometimes it displays [x] Closest Mirror. You refresh and you get [!] Closest Mirror. You refresh again and you get [x] Closest Mirror. Very confusing.
Comment 10 Vratislav Podzimek 2013-09-09 08:26:19 EDT
Samantha, are you aware of any recent changes that might have caused those issues?
Comment 11 Kamil Páral 2013-09-09 09:10:51 EDT
(In reply to Vratislav Podzimek from comment #10)
> Samantha, are you aware of any recent changes that might have caused those
> issues?

Maybe bug 1001081 is related? There were changes in installation source spoke.
Comment 12 Samantha N. Bueno 2013-09-09 09:22:34 EDT
(In reply to Kamil Páral from comment #11)
> (In reply to Vratislav Podzimek from comment #10)
> > Samantha, are you aware of any recent changes that might have caused those
> > issues?
> 
> Maybe bug 1001081 is related? There were changes in installation source
> spoke.

No, there were no changes to the source spoke resulting from that bug--that was a fix for pykickstart. There have not been any recent changes which should be causing this at all, actually, but I'll look into it.

One recent change which does affect the '!' and 'x' (not complete/complete) markers beside each spoke went in on 05 Sept though, 77cdb0f07d179ca89db4e0ee339af761038bde44. The spoke was incorrectly being detected as completed, which could affect whether you are able to re-visit it.
Comment 13 Kamil Páral 2013-09-09 12:17:51 EDT
Discussed at 2013-09-09 blocker review meeting [1]. This may end up being a package/mirror issue and needs more data. will revisit at the next review meeting.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-09/

I have done a few retries and it worked for me now, both with netinst and DVD. I'll test more and comment here.
Comment 14 Kamil Páral 2013-09-10 07:01:27 EDT
I have retried several times and I see no longer any problem (with TC4 or TC5). I'm withdrawing the blocker nomination. It was probably a broken mirror, but I'm not sure. Anaconda devs, can you find out the problem from the log files? Maybe anaconda could display a more helpful message in this case?
Comment 15 Samantha N. Bueno 2014-04-07 11:01:14 EDT
Closing this as NOTABUG since it was most likely a broken mirror.

Note You need to log in before you can comment on or make changes to this bug.