Bug 1001081 - anaconda unable to select INSTALLATION SOURCE (Exception yum.Errors.RepoError...)
anaconda unable to select INSTALLATION SOURCE (Exception yum.Errors.RepoError...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1001323 1001414 1001425 (view as bug list)
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-08-26 09:06 EDT by Reartes Guillermo
Modified: 2013-09-07 15:52 EDT (History)
14 users (show)

See Also:
Fixed In Version: pykickstart-1.99.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 09:55:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing the error (31.26 KB, image/png)
2013-08-26 09:06 EDT, Reartes Guillermo
no flags Details
anaconda.log (4.00 KB, text/plain)
2013-08-26 09:07 EDT, Reartes Guillermo
no flags Details
program.log (8.75 KB, text/plain)
2013-08-26 09:07 EDT, Reartes Guillermo
no flags Details
packaging.log (205.94 KB, text/plain)
2013-08-26 09:07 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-08-26 09:06:02 EDT
Created attachment 790518 [details]
screenshot showing the error

Description of problem:

When booting F20 aTC1, CD/DVD Installation Source cannot be selected. A yum error is shown and the only choice is Closest Mirror.

Version-Release number of selected component (if applicable):
F20 aTC1 (20.8-1)

How reproducible:

always


Steps to Reproduce:
1. Boot with 'text' and select 'text mode' when prompted.
2. try to change the installation source (by default is closest mirror
3. error.

Actual results:
unable to select CD/DVD as the Installation Source

Expected results:
Be able to select CD/DVD as the Installation Source

Additional info:
Comment 1 Reartes Guillermo 2013-08-26 09:07:03 EDT
Created attachment 790519 [details]
anaconda.log
Comment 2 Reartes Guillermo 2013-08-26 09:07:25 EDT
Created attachment 790520 [details]
program.log
Comment 3 Reartes Guillermo 2013-08-26 09:07:48 EDT
Created attachment 790521 [details]
packaging.log
Comment 4 Reartes Guillermo 2013-08-26 09:22:29 EDT
It appears that this is not text mode specific, i cannot select CD/DVD or NFS even in graphical mode.
Comment 5 Tim Flink 2013-08-26 15:55:39 EDT
I'm also seeing this on graphical install using x86_64 DVD in a VM
Comment 6 Tim Flink 2013-08-26 16:00:12 EDT
Proposing as a blocker for F20 alpha due to violation of the following F20 alpha release criterion [1]:

When using the DVD image, the installer must be able to use the DVD as a package source.

[1] http://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#DVD_package_source
Comment 7 Mukundan Ragavan 2013-08-26 22:07:46 EDT
*** Bug 1001323 has been marked as a duplicate of this bug. ***
Comment 8 Mukundan Ragavan 2013-08-26 22:09:30 EDT
Adding myself to CC.

Reported 1001323 without noticing this bug. Closed bz#1001323
Comment 9 Andre Robatino 2013-08-26 22:12:59 EDT
Seeing this right now on a minimal 20 Alpha TC1 i386 DVD text install.
Comment 10 Steve Tyler 2013-08-27 00:09:01 EDT
Procedure using graphical install:

Start installer from DVD:
$ qemu-kvm -m 4096 -hda f20-test-3.img -cdrom ~/xfr/fedora/F20/Alpha/Fedora-20-Alpha-TC1-x86_64-DVD.iso -vga std -boot menu=on

Proceed to Installation Summary with default language "English (United States)".
Note that Installation Source is "Closest mirror" (after some delay).

Click Installation Source.
Note that "Auto-detected installation media:" is selected:
    Device: sr0
    Label: Fedora_20-Alpha-TC1_x86_64
Check "Don't install the latest available software updates. ...".
Click Done.
Note that Installation Source is "Closest mirror".

Click Installation Source.
Note that "Don't install the latest available software updates. ..." is now unchecked.
Comment 11 David Shea 2013-08-27 14:44:56 EDT
This issue was fixed in pykickstart-1.99.37-1. It looks like .37 wasn't built on the f20 tag.
Comment 12 David Shea 2013-08-28 10:02:15 EDT
*** Bug 1001425 has been marked as a duplicate of this bug. ***
Comment 13 David Shea 2013-08-28 10:03:30 EDT
*** Bug 1001414 has been marked as a duplicate of this bug. ***
Comment 14 Kamil Páral 2013-08-28 13:16:15 EDT
Discussed at 2013-08-28 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion: "When using the DVD image, the installer must be able to use the DVD as a package source." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-28/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#DVD_package_source
Comment 15 lnie 2013-08-29 01:20:36 EDT
still occur in TC2
Comment 16 Andre Robatino 2013-08-29 02:32:26 EDT
With 20 Alpha TC2 DVD minimal text installs (both i386 and x86_64), the default choice was "Closest mirror", but I was able to change this to "CD/DVD drive", and it then installs without downloading packages. I still get the yum exception when changing the Installation source, though.
Comment 17 Andre Robatino 2013-08-29 03:15:16 EDT
I'm in the middle of a GUI install from the 20 Alpha TC2 x86_64 DVD. Like text mode, it chose "Closest mirror" by default. But if I go into the "Installation source" spoke, it then shows the DVD as the installation source, but the "Don't download updates" box is unchecked (I hope that's unintentional). If I check that box and exit the spoke, it then shows "CD/DVD drive" as the installation source, and it does not download packages during the install.
Comment 18 Petr Schindler 2013-08-29 08:36:49 EDT
Bug is still present in TC2 where is pykickstart-1.99.37-1.

Current behaviour:
It shows (and uses) "Closest mirror" when you get to "hub". If I go to Installation source and immediately click on 'done', then it changes to DVD repo.
Comment 19 David Shea 2013-08-29 13:35:55 EDT
So we're clear, in TC2 you can enter the installation source spoke and change the source to the DVD and that works, which it did not in TC1. The problem now is that the initial value for the installation source before you enter the spoke is invalid.
Comment 20 Andre Robatino 2013-09-03 05:57:47 EDT
Confirmed that if I go into the Installation source spoke and immediately exit, it changes the source to the DVD, and if I then go back into the spoke, the "don't download updates" box is now checked.
Comment 21 David Shea 2013-09-03 13:34:35 EDT
Fix for the initial installation source value is in commit 0ba9bd4a46a3f0486e9f24931170bbbcc623c405.
Comment 22 Andre Robatino 2013-09-05 16:28:19 EDT
Appears fixed in 20 Alpha TC4 in all cases I could check (64-bit GUI install, 32- and 64-bit text install).
Comment 23 Kamil Páral 2013-09-06 09:55:38 EDT
Fix confirmed in text and GUI as well. Alpha TC4.

Note You need to log in before you can comment on or make changes to this bug.