Bug 1005257 - [PATCH] Small typo fixes
[PATCH] Small typo fixes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
All All
low Severity low
: ---
: ---
Assigned To: Dustin Black
: EasyFix, Triaged
Depends On:
Blocks: 1342275
  Show dependency treegraph
 
Reported: 2013-09-06 10:15 EDT by purpleidea
Modified: 2017-03-27 14:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1342275 (view as bug list)
Environment:
Last Closed: 2017-03-27 14:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
small typo fixes (6.34 KB, patch)
2013-09-06 10:15 EDT, purpleidea
no flags Details | Diff

  None (edit)
Description purpleidea 2013-09-06 10:15:07 EDT
Created attachment 794778 [details]
small typo fixes

Small typo fixes, patch is straight forward and should apply easily.

Cheers,
James
Comment 1 Jiffin 2015-12-01 07:21:38 EST
Can you send the attached patch to upstream, If the issue is still exists.
Comment 2 Dustin Black 2016-06-02 16:13:54 EDT
Checked against current mainline, and all of these typos appear to be corrected.

However, I uncovered one more in the process.

--- a/xlators/nfs/server/src/nfs.c      2016-06-02 16:09:14.944255997 -0400
+++ b/xlators/nfs/server/src/nfs.c      2016-06-02 12:31:26.705631769 -0400
@@ -1885,7 +1885,7 @@
           .default_value = "none",
           .description = "Reject a comma separated list of addresses and/or"
                          " hostnames from connecting to the server. By default,"
-                         " all connections are allowed. This allows users to "
+                         " all connections are allowed. This allows users to"
                          "define a general rule for all exported volumes."
         },
         { .key  = {"rpc-auth.addr.*.allow"},
Comment 3 Vijay Bellur 2016-06-02 16:16:34 EDT
REVIEW: http://review.gluster.org/14620 (Very very minor typo fix in xlators/nfs/server/src/nfs.c Added space to .description; related to BZ 1005257) posted (#1) for review on release-3.8 by Dustin Black (dblack@redhat.com)
Comment 4 Dustin Black 2016-06-02 16:23:25 EDT
Patched in release-3.8 branch.
http://review.gluster.org/#/c/14620/1


I'm guessing I should have patched this at the master... still building my git/gerrit chops.
Comment 5 Vijay Bellur 2016-06-02 16:38:59 EDT
REVIEW: http://review.gluster.org/14621 (Very very minor typo fix in xlators/nfs/server/src/nfs.c Added space to .description; related to BZ 1005257) posted (#1) for review on master by Dustin Black (dblack@redhat.com)
Comment 6 Vijay Bellur 2016-06-06 12:21:51 EDT
REVIEW: http://review.gluster.org/14621 (nfs: fix a typo in the help text for option rpc-auth.addr.reject) posted (#2) for review on master by Dustin Black (dblack@redhat.com)
Comment 7 Vijay Bellur 2016-06-06 16:20:32 EDT
COMMIT: http://review.gluster.org/14621 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 9b4169255224b725e7d3455c63e2f9db33b0f3bf
Author: Dustin Black <dblack@redhat.com>
Date:   Thu Jun 2 16:15:25 2016 -0400

    nfs: fix a typo in the help text for option rpc-auth.addr.reject
    
    Added space to .description
    
    Reported-by: James Shubin <purpleidea@gmail.com>
    Change-Id: Ie4dd8774567ac4d8e1e8ec39aa3ab595d037101a
    BUG: 1005257
    Signed-off-by: Dustin Black <dblack@redhat.com>
    Reviewed-on: http://review.gluster.org/14621
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 8 Shyamsundar 2017-03-27 14:12:03 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.