Bug 100532 - gnome-display-properties settings don't survive across logins
gnome-display-properties settings don't survive across logins
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-23 02:48 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 12:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-07-23 02:48:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I'd expected the properties set with Preferences -> Screen resolution to be
retained across logins, but they aren't: every login session starts with the
default resolution, and the user has to change preferences again to get the
chosen resolution.

Version-Release number of selected component (if applicable):
control-center-2.2.2-1

How reproducible:
Always

Steps to Reproduce:
1.Log in
2.Start Preferences -> Screen Resolution
3.Change the resolution, mark it as applying to this host only, and confirm the
change.
4.Log out
5.Log in again, immediately (no networking, hostname or any such changes)

Actual Results:  Resolution will not be the one selected in the previous login

Expected Results:  I understand it should be, but is this a bug or an
enhancement request?

Additional info:
Comment 1 Alexander Larsson 2003-09-04 07:37:13 EDT
That is a bug. This should work, and does for me.
However, can you please try again with the latest control-center and
gnome-session from rawhide? We've now gone from the gnome 2.2 backport we had to
the normal code in gnome 2.4.

Its also possible that you upgraded control-center but not gnome-session, and
gnome-session is what sets the resolution on login.
Comment 2 Alexandre Oliva 2003-09-04 17:35:21 EDT
Err...  Are you sure you marked it as `host only', as per the instructions to
duplicate the problem?  I've just verified that it indeed works if applied to
all hosts, but gconf-editor doesn't show any entries other than default within
the screen section, where I'd have expected to find host-specific configurations.
Comment 3 Jonathan Blandford 2003-09-12 11:10:39 EDT
I can duplicate this too.  investigating.
Comment 4 Josiah Royse 2003-11-06 08:57:02 EST
I get this between two computers on a NFS mounted home directory.  I
figured my problem was a gnome gconfd-2 locking issue.  If logging in
and out quickly duplicates this, possibly gconfd-2 hasn't shutdown,
since it usually hangs around for a minute or two after user logout. 
This file locking is noticable when the home directory won't umount if
a user selects "reboot/shutdown" from the logout menu.
Comment 5 Ray Strode [halfline] 2005-05-12 11:46:20 EDT
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)
Comment 6 Alexandre Oliva 2005-05-12 12:57:00 EDT
Problem is fixed in FC3, maybe even in FC2.

Note You need to log in before you can comment on or make changes to this bug.