Bug 1005334 - Unable to login using smart card after adding the coolkey module to /etc/pki/nssdb
Unable to login using smart card after adding the coolkey module to /etc/pki/...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coolkey (Show other bugs)
6.5
i386 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 12:39 EDT by Roshni
Modified: 2013-11-21 18:06 EST (History)
3 users (show)

See Also:
Fixed In Version: coolkey-1.1.0-30.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:06:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1699 normal SHIPPED_LIVE coolkey bug fix and enhancement update 2013-11-20 16:52:09 EST

  None (edit)
Description Roshni 2013-09-06 12:39:36 EDT
Description of problem:
Unable to login using smartcard after adding coolkey module to /etc/pki/nssdb. pklogin_finder shows an error load_pkcs11_module() failed.

Version-Release number of selected component (if applicable):
RHEL 6.5
coolkey-1.1.0-29.el6
pam_pkcs11-0.6.2-13.el6

How reproducible:
always

Steps to Reproduce:
1. Setup kerberos for smartcard login.
2. Login to RHEL 6.5 Client machine using the smart card and check if the kerberos creds can be obtained.
3. Add the coolkey module to /etc/pki/nssdb/ as follows
modutil -add "CoolKey PKCS#11 Module" -dbdir /etc/pki/nssdb -libfile /usr/lib/pkcs11/libcoolkeypk11.so
4. Logout and try to select the smartcard login option.

Actual results:
The smart card login option cannot be selected. Login as local user and execute pklogin_finder debug, fails to recognize the card with error: load_pkcs11_module() failed

Expected results:
Should be able to login using smartcard and kerberos credentials should be valid

Additional info:
Comment 2 Bob Relyea 2013-09-06 17:23:08 EDT
The basic problem is pk11install only works with paths, not sql: or dbm: paths.
Comment 4 Roshni 2013-09-09 14:35:45 EDT
When the build in the errata is installed, the PKCS#11 Coolkey Module is automatically added to /etc/pki/nssdb and smartcard login works fine.

If the PKCS#11 Coolkey Module is deleted and added back again, the issue described in this bug is seen (unable to login using smartcard)
Comment 5 Bob Relyea 2013-09-09 14:39:44 EDT
Roshni, please to ls -s /etc/pki/nssdb

if pkcs11.txt does not have group other read, hand change it. There is an NSS bug against this issue.
Comment 6 Roshni 2013-09-09 16:41:42 EDT
I changed the permission of group other to read for the file pkcs11.txt, the issue still exists.
Comment 7 Bob Relyea 2013-09-09 17:51:26 EDT
Roshni, can you point me to your machines that are misbehaving?
Comment 9 Roshni 2013-09-16 13:13:28 EDT
Bob,

The machine is ready, you can have a look at the issue. Let me know if you need any more information from my side.
Comment 10 Roshni 2013-09-25 15:17:36 EDT
Coolkey seem seems to be working fine, the bug seems to be on the pam_pkcs11 component as in bug https://bugzilla.redhat.com/show_bug.cgi?id=1012082
Comment 12 Bob Relyea 2013-11-11 20:19:16 EST
this was ultimately not a coolkey bug, the fix was elsewhwere, so no docs needed for coolkey.
Comment 13 errata-xmlrpc 2013-11-21 18:06:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1699.html

Note You need to log in before you can comment on or make changes to this bug.