Bug 100542 - (ACPI) PCMCIA network card fails; need pci=noacpi to get it working
(ACPI) PCMCIA network card fails; need pci=noacpi to get it working
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-23 04:43 EDT by Tim Waugh
Modified: 2013-07-02 22:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 16:13:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of acpidmp (78.10 KB, text/plain)
2003-07-29 06:42 EDT, Tim Waugh
no flags Details
output of dmidecode (71 bytes, text/plain)
2003-07-29 06:43 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2003-07-23 04:43:54 EDT
Description of problem:
When I boot the new kernel on my Dell Inspiron 3500 with xirc2 PCMCIA network
adapter, I get this:

Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
Yenta IRQ list 0098, PCI irq11
Socket status: 30000059
Yenta IRQ list 0098, PCI irq11
Socket status: 30000059
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x320-0x327 0x378-0x37f
0x388-0x38f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
ttyS1 at port 0x02f8 (irq = 3) is a 16550A
xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
xirc2ps_cs: RequestIRQ: Resource in use

It wants IRQ 9, but that is in use by acpi according to /proc/interrupts.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
100%

Steps to Reproduce:
1. Boot kernel.
    
Additional info:
With acpi=off provided on the command line I get:

Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
PCI: Found IRQ 11 for device 00:04.0
PCI: Sharing IRQ 11 with 00:04.1
PCI: Found IRQ 11 for device 00:04.1
PCI: Sharing IRQ 11 with 00:04.0
Yenta IRQ list 0298, PCI irq11
Socket status: 30000010
Yenta IRQ list 0298, PCI irq11
Socket status: 30000010
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x320-0x327 0x378-0x37f
0x388-0x38f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
ttyS1 at port 0x02f8 (irq = 3) is a 16550A
xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
divert: allocating divert_blk for eth0
eth0: Xircom: port 0x300, irq 9, hwaddr 00:80:C7:A4:42:72
eth0: MII link partner: 41e1
eth0: MII selected
eth0: media 100BaseT, silicon revision 4
Comment 1 Bill Nottingham 2003-07-28 16:17:42 EDT
Can you post the output of acpidmp and dmidecode?
Comment 2 Tim Waugh 2003-07-29 06:42:41 EDT
Created attachment 93215 [details]
output of acpidmp
Comment 3 Tim Waugh 2003-07-29 06:43:03 EDT
Created attachment 93216 [details]
output of dmidecode
Comment 4 Len Brown 2003-08-05 16:19:30 EDT
does it still boot with pci=noacpi ? 
if you have the part number on that network card handy let me know so i can find one. 
 
Comment 5 Tim Waugh 2003-08-05 16:27:07 EDT
I'm no longer using that machine, but I can track it down and try a test
tomorrow.  The card is a Xircom CreditCard Ethernet 10/100-REady, CE3B-100BTX.
Comment 6 Tim Waugh 2003-08-06 11:24:05 EDT
pci=noacpi seems to give a good result.
Comment 7 Len Brown 2003-08-06 23:55:45 EDT
I ordered the Xircom -- thanks -- though my laptop may not fail like the 3500.
Can you attach the /proc/interrupts file for success & failure cases, also the 
complete dmesg -- since ACPI will tell us about the interrupt links it sees.

Comment 8 Tim Waugh 2003-08-07 11:54:41 EDT
Grr, I can't get it to fail now with the current rawhide kernel. :-(

Since reporting the bug this machine has been reinstalled with RHL9.  I also no
longer have the modem card that was plugged in at the time.
Comment 9 Len Brown 2003-08-11 22:28:27 EDT
I used the identical (LAN) card in my Toshiba Sattelite Pro M10, which also uses 
uses yenta.  Stock Severn Beta1 seems to work fine. 
 
Comment 10 Jun Nakajima 2003-08-19 15:08:34 EDT
Can you clarify the current status? Without the modem card, it boots 
successfully and the network card works fine?
Comment 11 Tim Waugh 2003-08-20 05:54:42 EDT
I don't think anyone can reproduce the problem any more.  It might be that the
modem card had some bearing on the problem, but I no longer have access to that.
Comment 12 Len Brown 2003-08-21 20:33:33 EDT
Maybe you're looking in the wrong drawer -- the CE3B-100BTX is a LAN card, not a 
modem card;-) 
 
Comment 13 Tim Waugh 2003-08-22 04:10:19 EDT
Yes, the modem card is a separate card which I no longer have access to.  The
computer and LAN card I still have, but can't reproduce the problem any more
(since I lost access to the modem; the machine was also reinstalled at that
time).  I was theorising that the modem card being plugged in at the same time
might have had something to do with the problem.

Can't test it now though. :-(
Comment 14 Bill Nottingham 2003-10-21 16:13:20 EDT
Closing, please reopen if it persists.

Note You need to log in before you can comment on or make changes to this bug.