Bug 1005476 - environment variables from /etc/sysconfig/lirc not passed to the daemon
environment variables from /etc/sysconfig/lirc not passed to the daemon
Status: CLOSED DUPLICATE of bug 881976
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-09-07 08:13 EDT by George Machitidze
Modified: 2013-10-01 11:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-01 11:46:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description George Machitidze 2013-09-07 08:13:34 EDT
Description of problem:
Environment variables from /etc/sysconfig/lirc are not passed to the daemon when starting up with systemd

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install lirc
2. Change environment variables in /etc/sysconfig/lirc
3. systemctl lirc start
4. ps auxwf|grep lirc|grep -v grep

Actual results:
/usr/sbin/lircd --driver=default --device=/dev/lirc0

Expected results:
same with different values

Additional info:
looks like there's nothing about /etc/sysconfig/lirc in systemd unit file:
[root@giomacdesk ~]# cat /usr/lib/systemd/system/lirc.service 
Description=LIRC Infrared Signal Decoder

ExecStart=/usr/sbin/lircd --driver=default --device=/dev/lirc0 

Comment 1 Till Maas 2013-10-01 11:46:22 EDT

*** This bug has been marked as a duplicate of bug 881976 ***

Note You need to log in before you can comment on or make changes to this bug.