Bug 100549 - (ACPI) boot failure on Shuttle SN41G2
(ACPI) boot failure on Shuttle SN41G2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Mike McLean
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-23 07:11 EDT by Martin Waldenburg
Modified: 2013-07-02 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 07:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ACPI VT86/Award PCI interrupt patch. (12.21 KB, patch)
2003-08-21 18:52 EDT, Len Brown
no flags Details | Diff
console output from default severn BETA1 CDROM boot (8.48 KB, text/plain)
2003-09-27 22:27 EDT, Len Brown
no flags Details
console messages from severn BETA1 CDROM boot with pci=noacpi (7.37 KB, text/plain)
2003-09-27 23:02 EDT, Len Brown
no flags Details
console messages from severn BETA1 CDROM boot with acpi=off (5.06 KB, text/plain)
2003-09-27 23:27 EDT, Len Brown
no flags Details
dmidecode output (4.24 KB, text/plain)
2003-09-28 00:05 EDT, Len Brown
no flags Details
acpidmp output (77.18 KB, text/plain)
2003-09-28 00:05 EDT, Len Brown
no flags Details
dmesg output from booting 2.4.22-1.2051.nptl kernel (8.25 KB, text/plain)
2003-09-28 00:11 EDT, Len Brown
no flags Details
dmesg output from booting 2.4.22-1.2051.nptl kernel w/ acpi=force (11.83 KB, text/plain)
2003-09-28 00:23 EDT, Len Brown
no flags Details
dmesg output from booting 2.4.22-1.2061.nptl w/ acpi=force (11.84 KB, text/plain)
2003-09-29 11:53 EDT, Len Brown
no flags Details

  None (edit)
Description Martin Waldenburg 2003-07-23 07:11:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
severn doesn't boot on Shuttle SN41G2.

last visible message:
loading sbin/loader



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. insert CD1 and boot
2.
3.
    

Actual Results:  hanged with last visible message:
loading sbin/loader


Expected Results:  installation schould have started

Additional info:

AMD 2500 barton
Seagate IDE 120GB 7200rpm
Samsung DVD/CDRW combo
Comment 1 Jeremy Katz 2003-07-23 11:24:37 EDT
Does booting with 'linux acpi=off' help?

Other useful command line options to try are nofirewire and nousb.
Comment 2 Martin Waldenburg 2003-07-23 11:49:10 EDT
'linux acpi=off' does help
Comment 3 Martin Waldenburg 2003-07-23 13:21:49 EDT
at the first boot after installation
it hangs now at:
starting systemservices
setting the hostname
Comment 4 Bill Nottingham 2003-07-28 16:04:50 EDT
Can you boot the postinstall kernel with 'acpi=off' as well?

Also, can you post the output of 'dmidecode' (from the kernel-utils package)
Comment 5 Len Brown 2003-08-21 18:51:20 EDT
Didn't get the dmidecode output, but 
http://us.shuttle.com/specs2.asp?pro_id=284 says the mainboard in an 
"FN41" with North bridge-Nvidia nForce2, South bridge-nVidia MCP-T 
the manual says it has an AwardBIOS, so lets try the Award interrupt patch. 
 
Comment 6 Len Brown 2003-08-21 18:52:20 EDT
Created attachment 93844 [details]
ACPI VT86/Award PCI interrupt patch. 

This patch has fixed the ACPI interrupt problem for similar systems.
Please try applying it to a copy of your Severn BETA1 kernel to
see if works for you too:

~/src/linux-2.4.21-20.1.2024.2.1.nptl> patch -Np1 < ./pci_link-severn.patch
patching file arch/i386/kernel/io_apic.c
patching file arch/i386/kernel/mpparse.c
patching file drivers/acpi/pci_irq.c
patching file drivers/acpi/pci_link.c
patching file include/acpi/acpi_drivers.h
Comment 7 Len Brown 2003-09-27 22:27:14 EDT
Created attachment 94789 [details]
console output from default severn BETA1 CDROM boot
Comment 8 Len Brown 2003-09-27 23:02:40 EDT
Created attachment 94790 [details]
console messages from severn BETA1 CDROM boot with pci=noacpi

booted successfully, but didn't recognize the on-board Realtek 8201B NIC
for network install.
Comment 9 Len Brown 2003-09-27 23:27:59 EDT
Created attachment 94791 [details]
console messages from severn BETA1 CDROM boot with acpi=off

added Intel Pro100 NIC, booted acpi=off, and successfully network installed.
Comment 10 Len Brown 2003-09-28 00:05:25 EDT
Created attachment 94794 [details]
dmidecode output
Comment 11 Len Brown 2003-09-28 00:05:53 EDT
Created attachment 94795 [details]
acpidmp output
Comment 12 Len Brown 2003-09-28 00:11:27 EDT
Created attachment 94796 [details]
dmesg output from booting 2.4.22-1.2051.nptl kernel

went to http://rhn.redhat.com and downloaded the 2.4.22-1.2051.nptl kernel
from channel "Red Hat Linux (Severn) 9.0.93 - Beta Updates"
It booted on this box per the attached console messages.

but...
ACPI: Subsystem revision 20030813
ACPI: Interpreter disabled.
Comment 13 Len Brown 2003-09-28 00:23:25 EDT
Created attachment 94797 [details]
dmesg output from booting 2.4.22-1.2051.nptl kernel w/ acpi=force

The latest Red Hat kernel also boots if I manually force ACPI to be enabled
with cmdline acpi=force

/proc/interrupts is the same with acpi enabled or disabled, modulo the
the addition of the acpi interrupt:

[root@dhcppc12 shuttle]# cat /proc/interrupts
	   CPU0
  0:	  34366 	 XT-PIC  timer
  1:	      4 	 XT-PIC  keyboard
  2:	      0 	 XT-PIC  cascade
  3:	      0 	 XT-PIC  usb-ohci
  4:	    307 	 XT-PIC  serial
  5:	      0 	 XT-PIC  ehci_hcd
  8:	      1 	 XT-PIC  rtc
  9:	     53 	 XT-PIC  acpi
 10:	      3 	 XT-PIC  ohci1394
 11:	    956 	 XT-PIC  usb-ohci, eth0
 12:	     36 	 XT-PIC  PS/2 Mouse
 14:	   4089 	 XT-PIC  ide0
 15:	     22 	 XT-PIC  ide1
NMI:	      0
ERR:	      0
[root@dhcppc12 shuttle]#
Comment 14 Dave Jones 2003-09-28 21:38:59 EDT
beta2 works fine then I guess ?
Comment 15 Martin Waldenburg 2003-09-29 04:59:28 EDT
beta2 did not recognize my Sony G400 monitor
the rest went fine
Comment 16 Dave Jones 2003-09-29 07:42:42 EDT
The monitor issue is seperate from this bug. Please open a separate bug report
for that.
Comment 17 Len Brown 2003-09-29 11:53:52 EDT
Created attachment 94822 [details]
dmesg output from booting 2.4.22-1.2061.nptl w/ acpi=force

yes, Fedora beta2 boots fine with acpi=force.
This option is needed because the kernel shipped with acpi_disabled by default.
Comment 18 Dave Jones 2003-09-29 12:29:42 EDT
Does it boot & work ok without acpi too ?

Note You need to log in before you can comment on or make changes to this bug.