Bug 1005533 - Upgrade script missing field in vm_template
Upgrade script missing field in vm_template
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity high
: ---
: 3.3.1
Assigned To: Eli Mesika
virt
: Reopened
: 1021146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-08 03:17 EDT by Shahar Havivi
Modified: 2013-11-25 07:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 07:06:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20348 None None None Never

  None (edit)
Description Shahar Havivi 2013-09-08 03:17:42 EDT
Commit: http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=0c47b30468b855e5c52b120f476d97cc754852ee
add single_qxl_pci field to vm_static and vm_template tables but fail to add the this field for vm_template (vm_static do upgrade).

This is causing upgrade failure.
Comment 1 Itamar Heim 2013-09-09 00:04:15 EDT
please backport to 3.3 branch
Comment 2 Eli Mesika 2013-09-09 04:50:53 EDT
Upgrade from beta to nightly is not supported 
Explanation :

The upgrade scripts are re-numbered when taken from nightly and back-ported into the 3.3 beta branch 
For example , the current latest upgrade scripts in the 3.3 beta branch are:
03_03_0650_allow_single_logic_for_policy_unit.sql ...
03_03_0660_add_enabled_column_to_policy_unit.sql ...
03_03_0670_add_description_to_policy_unit.sql ...
03_03_0680_remove_migration_domain_filter.sql ...

looking in the specific script that added single_qxl_pci field , its number in nighthly is 03_03_0650 and it was not ported yet to the beta branch

Therefor, when upgrading from 3.3 beta to nightly, since the latest script in the 3.3 beta DB is 03_03_0680, upgrade will start from 03_03_0690 and the nightly 03_03_0650 will be omitted and will cause the above error.

So, either use a clean install on the beta branch and install only beta releases or use clean install nightly and use nightly releases

You can upgrade from nighthly to nightly and from beta to to beta. but upgrade from beta to nightly is not supported
Comment 3 Jason Brooks 2013-10-18 20:28:21 EDT
Is stable to beta upgrade supported? I'm hitting this same issue with 3.3.0.1 to 3.3.1 beta.
Comment 4 Shahar Havivi 2013-10-20 04:58:47 EDT
(In reply to Jason Brooks from comment #3)
> Is stable to beta upgrade supported? I'm hitting this same issue with
> 3.3.0.1 to 3.3.1 beta.
The current beta have an upgrade error
http://lists.ovirt.org/pipermail/users/2013-October/017261.html
Comment 5 Eli Mesika 2013-10-21 04:09:52 EDT
re-opening for fixing the 3.3.0.1 to 3.3.1 beta upgrade :

here are 2 updates that have wrong numbering in 3.3.1 Beta :

1) 03_03_0650_add_signle_qxl_pci_column.sql => this change will not be installed in the upgrade since the latest change was 0680
2) 03_03_0680_add_cpu_shares_to_vm.sql => this script will also be skipped

The fix to that is to add the following scripts to 3.3.1.Beta which are exact copies of 1) and 2) from above as :

03_03_0681_add_cpu_shares_to_vm.sql
03_03_0682_add_signle_qxl_pci_column.sql
Comment 6 Sandro Bonazzola 2013-10-21 10:23:30 EDT
*** Bug 1021146 has been marked as a duplicate of this bug. ***
Comment 7 Sandro Bonazzola 2013-11-25 07:06:16 EST
oVirt 3.3.1 has been released

Note You need to log in before you can comment on or make changes to this bug.