Bug 1021146 - 3.3.0 to 3.3.1 beta upgrade fails on missing database column
3.3.0 to 3.3.1 beta upgrade fails on missing database column
Status: CLOSED DUPLICATE of bug 1005533
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.1
Assigned To: Eli Mesika
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 16:53 EDT by Jason Brooks
Modified: 2013-10-21 10:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 10:23:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Brooks 2013-10-19 16:53:09 EDT
Description of problem:

I hit a bump upgrading from 3.3.0.1 to 3.3.1 beta on Fedora 19. Installer tries to create a view including a column not yet in the db. This seems to be the same issue as reported in the closed bz1005533.

Error message from log below:


2013-10-18 16:38:14 DEBUG otopi.plugins.ovirt_engine_setup.db.schema
plugin.execute:446 execute-output:
['/usr/share/ovirt-engine/dbscripts/upgrade.sh', '-s', 'localhost',
'-p', '5432', '-u', 'engine', '-d', 'engine', '-l',
'/var/log/ovirt-engine/setup/ovirt-engine-setup-20131018163438.log',
'-g'] stderr:
psql:create_views.sql:400: ERROR:  column vm_templates.single_qxl_pci
does not exist
LINE 18:        vm_templates.single_qxl_pci as single_qxl_pci,
                ^

2013-10-18 16:38:14 DEBUG otopi.context context._executeMethod:137
method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 127, in
_executeMethod
    method['method']()
  File
"/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/db/schema.py", line 261, in _miscUpgrade
    osetupcons.DBEnv.PGPASS_FILE
  File "/usr/lib/python2.7/site-packages/otopi/plugin.py", line 451, in
execute
    command=args[0],
RuntimeError: Command '/usr/share/ovirt-engine/dbscripts/upgrade.sh'
failed to execute
2013-10-18 16:38:14 ERROR otopi.context context._executeMethod:146
Failed to execute stage 'Misc configuration': Command
'/usr/share/ovirt-engine/dbscripts/upgrade.sh' failed to execute


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Sandro Bonazzola 2013-10-21 10:23:30 EDT
(In reply to Jason Brooks from comment #0)
> Description of problem:
> 
> I hit a bump upgrading from 3.3.0.1 to 3.3.1 beta on Fedora 19. Installer
> tries to create a view including a column not yet in the db. This seems to
> be the same issue as reported in the closed bz1005533.

It really is the same issue as reported in the closed bz1005533. The bug has been reopened, closing this as duplicate.

*** This bug has been marked as a duplicate of bug 1005533 ***

Note You need to log in before you can comment on or make changes to this bug.