Bug 1005788 - Trying to export a template with 2 disks again after a previously failed export attempt fails because rollback doesn't delete the disk
Trying to export a template with 2 disks again after a previously failed expo...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Maor
Meital Bourvine
storage
: AutomationBlocker, Regression, Reopened
: 964690 (view as bug list)
Depends On:
Blocks: 3.3snap3
  Show dependency treegraph
 
Reported: 2013-09-09 08:05 EDT by Meital Bourvine
Modified: 2016-02-10 11:58 EST (History)
16 users (show)

See Also:
Fixed In Version: is25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-16 06:56:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abaron: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19161 None None None Never
oVirt gerrit 20651 None None None Never
oVirt gerrit 21568 None None None Never
oVirt gerrit 21640 None None None Never

  None (edit)
Comment 2 Sergey Gotliv 2013-09-10 11:11:22 EDT
*** Bug 964690 has been marked as a duplicate of this bug. ***
Comment 8 Itamar Heim 2013-10-29 11:26:59 EDT
Description of problem:
Trying to import a template with 2 disks again after a previously failed import attempt fails because rollback doesn't delete the disk. Error:
<detail>[Cannot copy Template. The following disks already exist: vm_281164_Disk1. Please import as a clone.]</detail>

Version-Release number of selected component (if applicable):
is13 - Regression

How reproducible:
95%

Steps to Reproduce:
1. Create a VM with 2 disks
2. Create a template
3. Start importing the template
4. Wait until the first disk finished importing
5. Restart vdsm (to fail the import)
6. Try to import again

Actual results:
Can't import becasue the first disk wasn't remove during rollback.

Expected results:
Rollback will remove the disk, and importing on the second time will succeed.
Comment 12 Itamar Heim 2014-01-21 17:23:38 EST
Closing - RHEV 3.3 Released
Comment 13 Itamar Heim 2014-01-21 17:24:40 EST
Closing - RHEV 3.3 Released
Comment 14 Itamar Heim 2014-01-21 17:28:19 EST
Closing - RHEV 3.3 Released
Comment 15 Ohad Basan 2014-03-05 08:49:13 EST
we see this problem again on rhev 3.4
Comment 18 Maor 2014-03-12 13:44:06 EDT
The bug is related to the import process.
and the specific test described in comment16 fails on *export* VM not import.
The test had never ran successfully, and should be fixed instead.
Comment 23 Maor 2014-09-01 09:12:14 EDT
Removing needinfo after Eyal and Sergey's comments

Note You need to log in before you can comment on or make changes to this bug.