Bug 964690 - vdsm: can't import a vm after vdsm restart during import of the same vm
vdsm: can't import a vm after vdsm restart during import of the same vm
Status: CLOSED DUPLICATE of bug 1005788
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Aharon Canan
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 10:41 EDT by Dafna Ron
Modified: 2016-02-10 12:13 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 11:11:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abaron: Triaged+


Attachments (Terms of Use)
logs (1.38 MB, application/x-gzip)
2013-05-19 10:41 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2013-05-19 10:41:00 EDT
Created attachment 750060 [details]
logs

Description of problem:

I imported a vm and restarted vdsm during the import. 
After we reselected an SPM I tried to import the same vm again and failed with error from vdsm: 

9d55e05d-f651-4172-8646-42385dbcc03b::ERROR::2013-05-19 17:21:19,938::task::850::TaskManager.Task::(_setError) Task=`9d55e05d-f651-4172-8646-42385dbcc03b`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 318, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 68, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1708, in copyImage
    volType, volFormat, preallocate, postZero, force)
  File "/usr/share/vdsm/storage/image.py", line 829, in copy
    srcImgUUID=volume.BLANK_UUID, srcVolUUID=volume.BLANK_UUID)
  File "/usr/share/vdsm/storage/blockSD.py", line 610, in createVolume
    volUUID, desc, srcImgUUID, srcVolUUID)
  File "/usr/share/vdsm/storage/volume.py", line 476, in create
    srcVolUUID, imgPath, volPath)
  File "/usr/share/vdsm/storage/blockVolume.py", line 166, in _create
    initialTag=TAG_VOL_UNINIT)
  File "/usr/share/vdsm/storage/lvm.py", line 1016, in createLV
    raise se.CannotCreateLogicalVolume(vgName, lvName)
CannotCreateLogicalVolume: Cannot create Logical Volume: ('38755249-4bb3-4841-bf5b-05f4a521514d', '6b42d637-0c96-4fa9-8e58-a8d62814cc0f')

Version-Release number of selected component (if applicable):

sf17

How reproducible:

100%

Steps to Reproduce:
1. create a vm from template and export both vm and template
2. remove the vm and template from the export domain
3. import the vm with collapse and restart vdsm during the import
4. after we select a different spm try to import the vm again. 
  
Actual results:

we fail to import the vm with error in vdsm: 
9d55e05d-f651-4172-8646-42385dbcc03b::ERROR::2013-05-19 17:21:19,938::task::850::TaskManager.Task::(_setError) Task=`9d55e05d-f651-4172-8646-42385dbcc03b`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 318, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 68, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1708, in copyImage
    volType, volFormat, preallocate, postZero, force)
  File "/usr/share/vdsm/storage/image.py", line 829, in copy
    srcImgUUID=volume.BLANK_UUID, srcVolUUID=volume.BLANK_UUID)
  File "/usr/share/vdsm/storage/blockSD.py", line 610, in createVolume
    volUUID, desc, srcImgUUID, srcVolUUID)
  File "/usr/share/vdsm/storage/volume.py", line 476, in create
    srcVolUUID, imgPath, volPath)
  File "/usr/share/vdsm/storage/blockVolume.py", line 166, in _create
    initialTag=TAG_VOL_UNINIT)
  File "/usr/share/vdsm/storage/lvm.py", line 1016, in createLV
    raise se.CannotCreateLogicalVolume(vgName, lvName)
CannotCreateLogicalVolume: Cannot create Logical Volume: ('38755249-4bb3-4841-bf5b-05f4a521514d', '6b42d637-0c96-4fa9-8e58-a8d62814cc0f')


Expected results:

we should succeed to export the  vm


Additional info: logs
Comment 7 Sergey Gotliv 2013-09-10 11:11:22 EDT

*** This bug has been marked as a duplicate of bug 1005788 ***

Note You need to log in before you can comment on or make changes to this bug.