Bug 100583 - ical (1) doesn't work on Redhat 9.
ical (1) doesn't work on Redhat 9.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ical (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Jay Turner
:
: 101164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-23 11:48 EDT by phil
Modified: 2015-01-07 19:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-03 04:16:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update to spec file for RHL9 (836 bytes, patch)
2003-08-09 22:08 EDT, Jens Petersen
no flags Details | Diff
patch to configure.in to point it at right tcl/tk script dirs (819 bytes, patch)
2003-08-09 22:15 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description phil 2003-07-23 11:48:38 EDT
Description of problem:
/usr/bin/ical doesn't work on Redhat 9.

Version-Release number of selected component (if applicable):
ical-2.2-26

How reproducible:
Always.

Steps to Reproduce:
1. Run '/usr/bin/ical'.

Actual results:  

Message to stderr:
/usr/bin/ical: error while loading shared libraries: libtk.so.0: cannot open
shared object file: No such file or directory

Expected results:
Expect X window to come up.

Additional info:
A workaround appears to be to copy /usr/lib/libtk.so.0 and libtcl.so.0
from a Redhat 7.3 machine to /usr/lib, and to make symlinks from
/usr/share/tk8.3 to /usr/lib/tk8.3 and from /usr/share/tcl8.3 to 
/usr/lib/tcl8.3, on the Redhat 9 machine.

Phil Kaslo
Dept. of Computer Science 520-621/2760
University of Arizona     phil@cs.arizona.edu 
Tucson, Ariz. 85721
Comment 1 Bob T. 2003-08-01 08:44:03 EDT
*** Bug 101164 has been marked as a duplicate of this bug. ***
Comment 2 Ngo Than 2003-08-03 04:16:13 EDT
ical is removed in RHL 9. if you want it working in RHL 9, you have to rebuild
it against new tcltk.
Comment 3 Jens Petersen 2003-08-09 22:08:55 EDT
Created attachment 93552 [details]
update to spec file for RHL9
Comment 4 Jens Petersen 2003-08-09 22:15:39 EDT
Created attachment 93553 [details]
patch to configure.in to point it at right tcl/tk script dirs
Comment 5 Bob T. 2003-08-10 08:24:58 EDT
Thanks for the patches.  I'm now getting this error:

configure: running /bin/sh './configure' --prefix=/usr 
'--host=i686-pc-linux-gnu' '--build=i686-pc-linux-gnu'
'--target=i386-redhat-linux' '--program-prefix=' '--prefix=/usr'
'--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin'
'--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include'
'--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var'
'--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
'--infodir=/usr/share/info' '--with-tclconfig=/usr/lib' 'CFLAGS=-O2 -g
-march=i386 -mcpu=i686' 'CXXFLAGS=-O2 -g -march=i386 -mcpu=i686'
'build_alias=i686-pc-linux-gnu' 'host_alias=i686-pc-linux-gnu'
'target_alias=i386-redhat-linux' --cache-file=/dev/null --srcdir=.
configure: warning: CFLAGS=-O2 -g -march=i386 -mcpu=i686: invalid host type
configure: warning: CXXFLAGS=-O2 -g -march=i386 -mcpu=i686: invalid host type
configure: error: can only configure for one host and one target at a time

But if I cd to the BUILD directory and do

./configure '--with-tclconfig=/usr/lib'

and then make, it builds okay.  Presumably the old/new architecture options 
are inconsistent.

Note You need to log in before you can comment on or make changes to this bug.