Bug 1005894 - rhq storage service not-installed while installing storage with start=false
rhq storage service not-installed while installing storage with start=false
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
4.9
x86_64 Windows
unspecified Severity medium (vote)
: ---
: RHQ 4.10
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-09-09 11:44 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-10 03:46:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage-install-start-false.png (481.94 KB, image/png)
2013-09-09 11:44 EDT, Armine Hovsepyan
no flags Details
storage-service-notInstalled.png (43.75 KB, image/png)
2013-09-09 11:45 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-09-09 11:44:34 EDT
Created attachment 795669 [details]
storage-install-start-false.png

Description of problem:
rhq storage service not-installed while installing storage with start=false

Version-Release number of selected component (if applicable):
48a76fe

How reproducible:
always

Steps to Reproduce:
1. run rhqctl.bat install --storage --storage-config ${path/to/rhq-storage.properties} - where rhq-storage.properties has start=false configuration  
2. run rhqctl.bat status
3. run rhqct.bat start --storage

Actual results:
after step1. storage with service-name installed with exit 0 present
after step2. storage node is not installed log is present
after step3.  the following log is printed: The rhqstorage-WIN-VGPR5DOPEJJ service is not installed - The specified service does not exist as an installed service. (0x424)

Expected results:
after step1. storage node service installed and not running
after step2. storage node not running log present
after step3. storage node should be started


Additional info:
screen-shots attached
Comment 1 Armine Hovsepyan 2013-09-09 11:45:58 EDT
Created attachment 795670 [details]
storage-service-notInstalled.png

workaround is possible: re-running rhqct.bat install --storage  -- which will install the service and start it, keeping the parameters given by previous installation operation
Comment 2 Jay Shaughnessy 2014-02-07 16:02:25 EST
Hi Armine, I think this BZ is out of date and can be closed.  We no longer have the "start" option in the rhq-storage.properties because we now have the separate rhqctl "install" and "start" commands.

If you agree, please close, otherwise please update with more details. Thanks.
Comment 3 Armine Hovsepyan 2014-02-10 03:46:22 EST
Hi Jay,

rhqctl install (start) covers this issue. Cosing as wontfix.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.