Bug 100616 - Error in the default configuration makes postfix unable to process any email
Error in the default configuration makes postfix unable to process any email
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
http://ketil.homeunix.net/postfix/my_...
:
: 100607 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-23 14:32 EDT by ketil V
Modified: 2013-08-27 14:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 19:56:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ketil V 2003-07-23 14:32:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The default settings for maximum size of incoming mail, and maximum size 
of users mailbox, are either wrong or ignored. The result is that 
incoming mail to valit users is accepted, but not processed to any 
mailbox. This includes all email the system sends to root.

To make Postfix process email, I have to set the settings manually

Version-Release number of selected component (if applicable):
postfix-1.1.11-11

How reproducible:
Always

Steps to Reproduce:
1. Install Postfix from the RPM in the RedHat CD
2. Configure Postfix to accept incoming email to the systems users
3. Send a email to any user, with minimum one letter in the body
    

Actual Results:  The mail get accepted, but do not enter any inbox. It seemes as
if it is regularily sent to /dev/null instead, because they vanish in the thin
air after a few days

Expected Results:  One of two:
- The email should not be accepted, reply to sender about server 
  problems
- The email should be processed and sent to its destination

Additional info:

I have put all my settings in the /etc/postfix - directory at
http://ketil.homeunix.net:8092/postfix/ including the maillog,
and a better report at 
http://ketil.homeunix.net:8092/postfix/my_configuration.html
Comment 1 ketil V 2003-07-26 14:57:59 EDT
I have changed the URL to the bugreport, it is now
http://ketil.homeunix.net/postfix/my_configuration.html.
Comment 2 ketil V 2003-07-26 14:59:24 EDT
*** Bug 100607 has been marked as a duplicate of this bug. ***
Comment 3 John Dennis 2004-01-21 12:54:52 EST
I've looked at the exact package you've got installed, both as an
installation RPM and the source code used during the build. I cannot
find anyway that message_size_limit or mailbox_size_limit would have
been incorrectly set in the RPM.

The fact that your main.cf.default lists:

mailbox_size_limit = 51200000
message_size_limit = 10240000

shows these are the correct defaults and that mailbox_size_limit
exceeds message_size_limit.

Note that postfix does not read main.cf.default to get its defaults,
rather the defaults are set at compile time via include files. The
postconf utility is used to generate the mail.cf.default file.
postconf is built using the same headers the postfix programs are
built with, this is how it knows what the defaults are. The
main.cf.default file is document for users what the defaults were at
build time. You could get non-default values in these variables is if
they had been set in your main.cf file. Note that the rpm should not
overwrite a pre-existing main.cf file.

Are you certain your main.cf did not have these values set?

At this point the only thing I can suggest if you want to track this
down more is the following:

Verify that your main.cf files does not have these values set.

Restart postfix, do you get the same error?

If so we need to log postfix's operation, adding "vv" to the options
setting in master.cf will turn on verbose logging at level two which
should dump configuration settings as they are read. Then search the
log for the two variables and attach the relevant parts of the log to
this bugzilla. In the future please don't put things on your own web
site, rather use bug attachments, otherwise we may lose parts of the
bug report.

If you don't get the same error after verifying main.cf does not set
these variables then please close this bug report.
Comment 4 John Dennis 2004-02-24 19:56:09 EST
I have not heard anything back so I'm closing this bug out. I don't
think there is a postfix bug here.
Comment 5 openshift-github-bot 2013-08-27 14:58:03 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/7f321c39c75455d28e294dadb0f7e3dfd786a437
Bug 100616

Use correct parameter for chown in Node.js install script

Note You need to log in before you can comment on or make changes to this bug.