Bug 1006248 - /etc/sysconfig/clock does nothing
/etc/sysconfig/clock does nothing
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 06:10 EDT by Tobias Brox
Modified: 2014-01-02 12:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 12:30:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 527830 None None None Never

  None (edit)
Description Tobias Brox 2013-09-10 06:10:04 EDT
Description of problem:

/etc/sysconfig/clock is not accessed during boot.  The file does nothing.  It's confusing, and should either be removed or replaced with some documentation.

Version-Release number of selected component (if applicable):

I chose "basesystem" because I can't find any more suitable component.

$ rpm -qf /etc/sysconfig/clock 
file /etc/sysconfig/clock is not owned by any package

... but it seems to exist on all RHEL6-machines I've checked at (as well as some derivative distributions).

How reproducible:

Always

Steps to Reproduce:
0. grep -r /etc/sysconfig/clock /etc/rc* /etc/init.d
1. Make sure atime is turned on the root file system
2. reboot
3. stat /etc/sysconfig/clock 

Actual results:

* No references to /etc/sysconfig/clock when grepping for it
* /etc/sysconfig/clock is not accessed during boot

Expected results:

File should be referenced from one of the init scripts, it should be accessed during boot, or it shouldn't exist at all if it's obsoleted.
Comment 2 Tobias Brox 2013-09-10 07:55:15 EDT
I got told that although /etc/sysconfig/clock is not used by RHEL, there may be legacy applications depending on this one, notably tomcat - http://grokbase.com/t/tomcat/users/051m0s38p2/how-to-change-the-timezone-for-tomcat#20050120zlgufj6cgdsma7i2olrgcpwia4 - although on my RHEL/Tomcat hosts /etc/localtime seems to be respected.

If the file has to exist for backward-compatibility with legacy apps, I suggest to at least add a comment of explanation in the file.
Comment 3 Ondrej Vasik 2013-09-10 10:51:05 EDT
Thanks for report, basesystem is definitely wrong, use distribution component when you are not sure what is responsible for this. In that case, AFAIK anaconda is creating the file, reassigning there.
Comment 4 RHEL Product and Program Management 2013-10-13 22:17:15 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Chris Lumens 2014-01-02 12:30:58 EST
Thanks for the bug report.  We have removed writing out this file from later versions of anaconda, so this will be fixed in RHEL-7.  See bug 859217.  If you require this fix in an update release of RHEL-6, please go through your support representation who will raise the issue for planning purposes.  Thanks again.

Note You need to log in before you can comment on or make changes to this bug.