Bug 1006304 - BootLoaderError: failed to set new efi boot target
BootLoaderError: failed to set new efi boot target
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:621f17b27646a41529ebfad28c1...
:
: 1066640 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 08:12 EDT by Petr Schindler
Modified: 2014-09-30 21:20 EDT (History)
24 users (show)

See Also:
Fixed In Version: anaconda-21.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-12 13:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (447.45 KB, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: anaconda.log (11.60 KB, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: environ (441 bytes, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: lsblk_output (3.41 KB, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: nmcli_dev_list (4.80 KB, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: program.log (72.84 KB, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: storage.log (308.50 KB, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
File: packaging.log (199 bytes, text/plain)
2013-09-10 08:12 EDT, Petr Schindler
no flags Details
anaconda.log (45.56 KB, text/x-log)
2013-12-31 14:51 EST, Robert Moskowitz
no flags Details
anaconda-tb (861.27 KB, text/plain)
2013-12-31 15:17 EST, Robert Moskowitz
no flags Details
syslog (132.18 KB, text/plain)
2013-12-31 15:21 EST, Robert Moskowitz
no flags Details
storage.log (118.19 KB, text/x-log)
2013-12-31 15:22 EST, Robert Moskowitz
no flags Details
program.log (118.19 KB, text/x-log)
2013-12-31 15:23 EST, Robert Moskowitz
no flags Details

  None (edit)
Description Petr Schindler 2013-09-10 08:12:01 EDT
Description of problem:
This bug appears in the end of installation when efi bootloader should be changed.

Version-Release number of selected component:
anaconda-20.12-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.12-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1664, in add_efi_boot_target
    raise BootLoaderError("failed to set new efi boot target")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1669, in install
    self.add_efi_boot_target()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1688, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2304, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 169, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
BootLoaderError: failed to set new efi boot target

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:UUID=AAD9-C18B ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
other involved packages: python-libs-2.7.5-7.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Null)
type:           anaconda
version:        20

Potential duplicate: bug 949786
Comment 1 Petr Schindler 2013-09-10 08:12:09 EDT
Created attachment 795970 [details]
File: anaconda-tb
Comment 2 Petr Schindler 2013-09-10 08:12:15 EDT
Created attachment 795971 [details]
File: anaconda.log
Comment 3 Petr Schindler 2013-09-10 08:12:19 EDT
Created attachment 795972 [details]
File: environ
Comment 4 Petr Schindler 2013-09-10 08:12:24 EDT
Created attachment 795973 [details]
File: lsblk_output
Comment 5 Petr Schindler 2013-09-10 08:12:28 EDT
Created attachment 795974 [details]
File: nmcli_dev_list
Comment 6 Petr Schindler 2013-09-10 08:12:34 EDT
Created attachment 795975 [details]
File: os_info
Comment 7 Petr Schindler 2013-09-10 08:12:38 EDT
Created attachment 795976 [details]
File: program.log
Comment 8 Petr Schindler 2013-09-10 08:12:43 EDT
Created attachment 795977 [details]
File: storage.log
Comment 9 Petr Schindler 2013-09-10 08:12:47 EDT
Created attachment 795978 [details]
File: ifcfg.log
Comment 10 Petr Schindler 2013-09-10 08:12:53 EDT
Created attachment 795979 [details]
File: packaging.log
Comment 11 Kamil Páral 2013-09-10 10:13:58 EDT
It seems that bug 947142 is back. Petr, can you please try another installation, whether the ASUS firmware can be convinced to run garbage collection at least through repeated installs?

Anaconda devs, could we maybe try to create a new placeholder UEFI variable _before_ the installation and modify the variable at the end, if everything works OK? That would circumvent this issue (or at least it would crash before actually modifying the disk). That of course assumes that modifying an existing variable works every time (we can verify that with kernel people).

Also, would it be possible to display a reasonable error message in this case? This UEFI problem is very obnoxious, common, and it seems we don't have a good solution for it. At least providing the users with short description (and ideally also a link for more detailed page) explaining why this failure happens and what they can do about it would be very helpful for them. Also they wouldn't blame Fedora and Anaconda for this problem.
Comment 12 Kamil Páral 2013-09-11 08:22:58 EDT
Next install worked fine, the garbage collector was triggered. I assume this is not a problem of just this single ASUS board, but more will behave the same - sometimes an installation will fail, but a further installation (which might require power off, not just reboot) will work OK. Leaving assigned to Anaconda, this is a badly designed hardware, but we should at least help our users to overcome the obstacle by informing them, if nothing else.
Comment 13 Mathieu Bridon 2013-09-20 05:17:43 EDT
I've just reproduced this bug with F20 Alpha RC4.

I think I've had it twice, but the first time ABRT decided it was a different bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1010203
Comment 14 Paul Robertson 2013-11-12 22:52:21 EST
USB install of F20 Beta, using the netinstall iso.

USB was correctly identified as an UEFI device at boot.

Using the standard partitioning I tried to install to sdf.  The drive had previous partitions from a failed attempt to install F19, which I removed.  I then used the default options for F20.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20-Beta
Comment 15 Paul Robertson 2013-11-18 19:25:40 EST
I found a work around that let me install Fedora.  I had to physically detach all other drives from my system, which results in /dev/sdf becoming /dev/sda.

After the install, I plugged all the drives back and everything appears to be working correctly.

(In reply to Paul Robertson from comment #14)
> USB install of F20 Beta, using the netinstall iso.
> 
> USB was correctly identified as an UEFI device at boot.
> 
> Using the standard partitioning I tried to install to sdf.  The drive had
> previous partitions from a failed attempt to install F19, which I removed. 
> I then used the default options for F20.
> 
> cmdline:        /usr/bin/python  /sbin/anaconda
> cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz
> inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 rd.live.check quiet
> hashmarkername: anaconda
> kernel:         3.11.6-301.fc20.x86_64
> package:        anaconda-20.25.6-1
> product:        Fedora
> reason:         BootLoaderError: failed to set new efi boot target
> release:        Cannot get release name.
> version:        20-Beta
Comment 16 Kodiak Firesmith 2013-11-20 10:47:33 EST
Tried to use anaconda in XFCE live spin to install a very typical LUKS + LVM setup.

Lenovo X120E that only bombs out on new Fedora Anaconda - all other Linux OSes are peachy.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-XFCE-x86_64-20-Beta- ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
other involved packages: python-libs-2.7.5-8.fc20.x86_64
package:        anaconda-20.25.6-1.fc20.x86_64
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 17 Martin Naď 2013-12-17 12:23:17 EST
try install Fedora on GPT/UEFI partition. installing grub fail.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=LIVE quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 18 mitch 2013-12-18 11:42:16 EST
Created USB boot disk using dd
dd if=Fedora.iso of=/dev/sdb

Selected the whole disk with automatic partitions.

click install.

Tried it twice.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-20-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: python-libs-2.7.5-9.fc20.x86_64
package:        anaconda-20.25.15-1.fc20.x86_64
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 19 Robert Moskowitz 2013-12-25 12:39:49 EST
Installing on a Lenovo x120e. 4GB memory, 320GB sata drive.  Replacing the old partitions, and pretty much default layout for the drive, but I increased swap to 8GB, reduced / to 30GB, and the rest to /home.

I have been having problems with this system with the current install of F17 with writing to standard USB drives or SD (No problem to optical, or HD USB devices).

Also changed my location to Detroit, and the hostname to lx120e.htt-consult.com.  And selected Admin tools.

All else was 'default'.

I earlier had this same failure on my new, blank SSD drive that I chose 'standard partitions' and layed out / and /home as ext4 partitions.  Same failure.

Next I am going to try an i386 installation.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 20 Robert Moskowitz 2013-12-25 14:56:15 EST
Lenovo x120e install onto SSD drive with x86_64 again.  Using the DVD install, but repo to my local server.

I think the problem is either my optical drive, the DVD I burned, or my USB port on this system.  It seems timing related to read the bootloader off the DVD.

Going to keep trying different combinations.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 rd.live.check quiet repo=http://repo.homebase.home.htt/fedora/20/os/x86_64/
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 21 Robert Moskowitz 2013-12-25 15:37:43 EST
Lenovo x86_64 install from netinstal CD using repo=mylocalrepo

Still hangs at installing bootloader.


cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 rd.live.check quiet repo=http://repo.homebase.home.htt/fedora/20/os/x86_64/
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 22 Robert Moskowitz 2013-12-31 12:19:12 EST
Another attempt to install f20 on my lenovo x120e

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 rd.live.check quiet repo=http://repo.homebase.home.htt/fedora/20/os/x86_64/
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 23 Robert Moskowitz 2013-12-31 14:51:28 EST
Created attachment 843899 [details]
anaconda.log
Comment 24 Robert Moskowitz 2013-12-31 15:17:11 EST
Created attachment 843904 [details]
anaconda-tb
Comment 25 Robert Moskowitz 2013-12-31 15:21:24 EST
Created attachment 843906 [details]
syslog
Comment 26 Robert Moskowitz 2013-12-31 15:22:13 EST
Created attachment 843907 [details]
storage.log
Comment 27 Robert Moskowitz 2013-12-31 15:23:15 EST
Created attachment 843908 [details]
program.log
Comment 28 Chris Murphy 2013-12-31 16:00:40 EST
(In reply to Robert Moskowitz from comment #27)
> program.log

17:08:21,599 INFO program: Running... efibootmgr -c -w -L Fedora -d /dev/sda -p 1 -l \EFI\fedora\shim.efi
17:08:21,793 DEBUG program: Return code: 1

Yet no kernel messages in syslog. I don't know if we need a dmesg -n7 before running the installer, or debug as a boot param, or a debug kernel to get more information on why setting the entry failed. In any case this particular report and its logs should probably be refiled against the kernel since efibootmgr makes kernel calls to do its job.
Comment 29 Robert Moskowitz 2013-12-31 16:32:41 EST
(In reply to Chris Murphy from comment #28)
> (In reply to Robert Moskowitz from comment #27)
> > program.log
> 
> 17:08:21,599 INFO program: Running... efibootmgr -c -w -L Fedora -d /dev/sda
> -p 1 -l \EFI\fedora\shim.efi
> 17:08:21,793 DEBUG program: Return code: 1
> 
> Yet no kernel messages in syslog. I don't know if we need a dmesg -n7 before
> running the installer, or debug as a boot param, or a debug kernel to get
> more information on why setting the entry failed. In any case this
> particular report and its logs should probably be refiled against the kernel
> since efibootmgr makes kernel calls to do its job.

Let me know if there is a specific test you wish me to perform.  I can make another go at it tomorrow.  It takes ~2hrs for the whole thing.
Comment 30 Chris Murphy 2013-12-31 17:00:59 EST
I suggest filing a new bug against the kernel, with a summary "efibootmgr fails to set new efi boot target when installing Fedora", and a brief description of how to reproduce this. For actual results I'd state that the installer fails to complete due to bootloadererror, and cite the program log lines I did in comment 28. In expected results, state you don't expect the bootloader to fail being installed, but also that syslog should contain kernel messages with more information on the nature of efibootmgr's failure to write to NVRAM.

In additional info, include computer model and firmware revision. And then attach your program.log, anaconda-tb, and syslog.

Also include as attachments the current results of:
efibootmgr -v > efibootmgr.txt
ls /sys/firmware/efi/efivars/ > efivars.txt

I wouldn't try to reproduce until you get more information from kernel maintainers on how to get the information they need.
Comment 31 Robert Moskowitz 2014-01-05 15:00:21 EST
tried after applying firmware update 1.17 to Lenovo x120e

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet repo=http://repo.homebase.home.htt/fedora/20/os/x86_64/
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 32 Matthew Ashman 2014-01-05 18:06:19 EST
Standard partitioning, using LVM with passphrase. Similar problem may have occurred with attempt at installation with BTRFS filesystem too.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-20-1 ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: python-libs-2.7.5-9.fc20.x86_64
package:        anaconda-20.25.15-1.fc20.x86_64
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 33 Edwind Richzendy Contreras Soto 2014-02-09 14:03:08 EST
Instaling fedora 20 LXDE spin

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-LXDE-x86_64-20-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: python-libs-2.7.5-9.fc20.x86_64
package:        anaconda-20.25.15-1.fc20.x86_64
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 34 Brian Lane 2014-02-19 19:54:04 EST
*** Bug 1066640 has been marked as a duplicate of this bug. ***
Comment 35 Taylor Smock 2014-04-11 09:27:06 EDT
Fujitsu T731: Bios version 1.09

Workaround (Warning: Can brick and will brick some laptops): set kernel command line to 
$(prev_command_line) efi_no_storage_paranoia


Source: https://bbs.archlinux.org/viewtopic.php?id=173710

I actually booted into a previously installation (that kind of worked), but it should work with the install media as well.

In my case, it appears that NVRAM is never garbage collected (multiple reboots/poweroffs between install attempts).

Other things to note: In my case, the Fedora Install replicated the entire EFI boot list (e.g., 0001: Bios, 0002: Recovery ... 0012: Bios, 0013: Recovery) and rendered the previous boot list unselectable from BIOS. It did manage to partially install grub (such that I got the grub command line).

I'm going to try reflashing the BIOS to see if that helps.
Comment 36 Taylor Smock 2014-04-11 13:05:36 EDT
Reflashing the BIOS with a force option appears to have fixed it for me. YMMV.

For those having this problem, search for a DOS update utility from the manufacturer, and use that. You will need to figure out out to "force" the update. In my case (Fujitsu T731), the default command for flashing did NOT fix the problem.

Example:
Default command:
-----
PFLASH /bbl /sv /sd CWVV109.ROM
-----
In that case, it updated/flashed everything besides the Variables and the GPNV (whatever that is). 

Modified command:
----
PFLASH /force CWVV109.ROM
----
In this case, it did everything that the default command did and the Variables and GPNV. It is likely that this command will vary between manufactureres (and probably between products) so read the README file if there is one. 
I should note that it appears to have wiped the Product Name and Serial Number from the BIOS. Also, while trying to fix this (prior to flashing), I did remove my ability to enter the BIOS and change boot order.
Comment 37 antoine 2014-04-15 06:48:16 EDT
In installation EFI Boot won't installed

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 38 Chris Murphy 2014-04-15 12:31:57 EDT
(In reply to antoine from comment #37)
> In installation EFI Boot won't installed

Need dmesg, /tmp/program.log, and ls -l /sys/firmware/efi/efivars/
Comment 39 Chris Murphy 2014-04-15 12:33:44 EDT
Should the component for this bug be switched to kernel? I don't see any of these related to the installer proper, either efibootmgr or kernel.
Comment 40 Brian Lane 2014-04-15 19:51:57 EDT
I was keeping this open to remind me about comment 11. There is already a kernel bug for the efivars failure that is causing this.

It happens enough that we should do a bit more to handle it and let the user know what's going on.
Comment 41 Chris Murphy 2014-04-15 22:40:36 EDT
OK that makes perfect sense. 

Sister bug 1033354 is (anaconda) failure to remove an existing NVRAM entry. I think it's OK for anaconda to conflate the two when notifying the user since both are "failure to modify NVRAM"; this is consistent with bug 1047993 "Kernel fails to make NVRAM changes for efibootmgr."

The plan to remove, then set, a Fedora boot entry before modifying the target disk would also obviate RFE bug 1049552, so it can be closed.
Comment 42 radactfx 2014-04-24 13:28:38 EDT
Setup gave this error during "Startup program installation" stage (or something like that, "Instalowanie programu startowego" in Polish). This may be connected to some HDD problems which result in (g)parted saying "The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes." and after ignoring "The partition's data region doesn't occupy the entire partition.".

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-20-1 ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: python-libs-2.7.5-9.fc20.x86_64
package:        anaconda-20.25.15-1.fc20.x86_64
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 43 Chris Murphy 2014-04-24 17:00:39 EDT
(In reply to radactfx from comment #42)
That's sufficiently unique that it might be best to investigate in a separate bug. If you can file a new bug and then post its bug ID number in this bug, I'll take a look at it. Please include:

/var/log/anaconda/anaconda.program.log
/var/log/anaconda/anaconda.storage.log
smartctl -i /dev/sdX  # for the target drive
efibootmgr -v
Comment 44 Brian Lane 2014-04-24 17:47:59 EDT
(In reply to Chris Murphy from comment #43)
> (In reply to radactfx from comment #42)
> That's sufficiently unique that it might be best to investigate in a
> separate bug. If you can file a new bug and then post its bug ID number in
> this bug, I'll take a look at it. Please include:
> 
> /var/log/anaconda/anaconda.program.log
> /var/log/anaconda/anaconda.storage.log

Or attach /tmp/anaconda-tb-* from the failed install which has all the logs in one file.
Comment 45 Silviu Hutanu 2014-05-02 07:33:15 EDT
IBM x3550 with UEFI

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 46 Evan Kinney 2014-05-08 14:32:00 EDT
Using Parallels Desktop 10 private beta on OS X 10.9.3. Set the machine type to Fedora and enabled EFI boot in the Parallels options. From what I see, this doesn't seem to necessarily be due to anything Parallels is doing.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 47 Chris Murphy 2014-05-08 15:16:26 EDT
(In reply to Evan Kinney from comment #46)
I'd split this out into a separate bug report against the kernel, and include the dmesg from a failed install attempt, and also include the /tmp/program.log which will help indicate whether it was a bootloader entry remove, or add, attempt.

I'm guessing there's a negative interaction between the kernel and the Parallels NVRAM implementation that's causing the efibootmgr add bootloader entry command to fail. So at this point it's an open question whose bug it is.

I'd also suggest filing a bug with Parallels, and cross reference the two bugs.
Comment 48 Mike Pittaro 2014-05-10 19:17:21 EDT
Happened during install.  No special install settings, very vanilla.

Motherboard is Intel DP67EPB3.

Seems like another instance of Bugzilla id 1006304

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         BootLoaderError: failed to set new efi boot target
release:        Cannot get release name.
version:        20
Comment 49 Mike Pittaro 2014-05-10 21:01:59 EDT
(In reply to Mike Pittaro from comment #48)
> Happened during install.  No special install settings, very vanilla.
> 
> Motherboard is Intel DP67EPB3.
> 

The install worked on a second try, with no problems.

Second try was a warm reboot, first was a cold boot.
Comment 50 Brian Lane 2014-05-12 13:14:55 EDT
Ok, this is 'fixed' in the sense that Anaconda will now handle BootLoaderErrors by prompting you to continue the installation or not. You may be able to fix the failure manually.

Problems with setting UEFI variables should probably be dupes against bug

Note You need to log in before you can comment on or make changes to this bug.