Bug 1010203 - BootLoaderError: failed to remove old efi boot entry
BootLoaderError: failed to remove old efi boot entry
Status: CLOSED DUPLICATE of bug 975537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:637383df30bd07157fdf78056cf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 04:41 EDT by Mathieu Bridon
Modified: 2013-09-20 08:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 08:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (842.44 KB, text/plain)
2013-09-20 04:42 EDT, Mathieu Bridon
no flags Details
File: anaconda.log (62.21 KB, text/plain)
2013-09-20 04:42 EDT, Mathieu Bridon
no flags Details
File: environ (518 bytes, text/plain)
2013-09-20 04:42 EDT, Mathieu Bridon
no flags Details
File: lsblk_output (3.01 KB, text/plain)
2013-09-20 04:42 EDT, Mathieu Bridon
no flags Details
File: nmcli_dev_list (13.01 KB, text/plain)
2013-09-20 04:42 EDT, Mathieu Bridon
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-20 04:42 EDT, Mathieu Bridon
no flags Details
File: program.log (94.91 KB, text/plain)
2013-09-20 04:43 EDT, Mathieu Bridon
no flags Details
File: storage.log (649.34 KB, text/plain)
2013-09-20 04:43 EDT, Mathieu Bridon
no flags Details
File: ifcfg.log (1.38 KB, text/plain)
2013-09-20 04:43 EDT, Mathieu Bridon
no flags Details
File: packaging.log (129 bytes, text/plain)
2013-09-20 04:43 EDT, Mathieu Bridon
no flags Details

  None (edit)
Description Mathieu Bridon 2013-09-20 04:41:57 EDT
Description of problem:
I used the Alpha RC4 live CD.

When the install failed, the label above the progress bar says « Installing bootloader ».

Version-Release number of selected component:
anaconda-20.18-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1640, in remove_efi_boot_target
    raise BootLoaderError("failed to remove old efi boot entry")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1668, in install
    self.remove_efi_boot_target()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1688, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2304, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 173, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
BootLoaderError: failed to remove old efi boot entry

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-20-Al ro rd.live.image quiet rhgb rd.live.check
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
other involved packages: python-libs-2.7.5-7.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

Potential duplicate: bug 950022
Comment 1 Mathieu Bridon 2013-09-20 04:42:32 EDT
Created attachment 800353 [details]
File: anaconda-tb
Comment 2 Mathieu Bridon 2013-09-20 04:42:38 EDT
Created attachment 800354 [details]
File: anaconda.log
Comment 3 Mathieu Bridon 2013-09-20 04:42:42 EDT
Created attachment 800355 [details]
File: environ
Comment 4 Mathieu Bridon 2013-09-20 04:42:46 EDT
Created attachment 800356 [details]
File: lsblk_output
Comment 5 Mathieu Bridon 2013-09-20 04:42:51 EDT
Created attachment 800357 [details]
File: nmcli_dev_list
Comment 6 Mathieu Bridon 2013-09-20 04:42:55 EDT
Created attachment 800358 [details]
File: os_info
Comment 7 Mathieu Bridon 2013-09-20 04:43:02 EDT
Created attachment 800359 [details]
File: program.log
Comment 8 Mathieu Bridon 2013-09-20 04:43:23 EDT
Created attachment 800360 [details]
File: storage.log
Comment 9 Mathieu Bridon 2013-09-20 04:43:28 EDT
Created attachment 800361 [details]
File: ifcfg.log
Comment 10 Mathieu Bridon 2013-09-20 04:43:31 EDT
Created attachment 800362 [details]
File: packaging.log
Comment 11 David Shea 2013-09-20 08:08:41 EDT

*** This bug has been marked as a duplicate of bug 975537 ***

Note You need to log in before you can comment on or make changes to this bug.