Bug 1006482 - Context button next to tab title does nothing
Context button next to tab title does nothing
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low
: ER4
: 6.0.0
Assigned To: Alexandre Porcelli
Radovan Synek
:
: 1008726 (view as bug list)
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-10 13:04 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-09-10 13:04:48 EDT
Description of problem:
There is a clickable button (three short horizontal lines) next to each tab/panel title. It does nothing, just confuses users.
Comment 3 Alexandre Porcelli 2013-09-11 23:50:56 EDT
in order to disable context navigation on listbar you have to do the following in your application startup (usually in your app entry point).

org.uberfire.client.UberFirePreferences.setProperty( "org.uberfire.client.workbench.widgets.listbar.context.disable", true );

Changes pushed to Uberfire in master and 0.3.x branches

https://github.com/droolsjbpm/uberfire/commit/548b745e4
https://github.com/droolsjbpm/uberfire/commit/bb0b5b03e
Comment 5 Alexandre Porcelli 2013-09-16 20:04:53 EDT
*** Bug 1008726 has been marked as a duplicate of this bug. ***
Comment 6 Alexandre Porcelli 2013-09-26 22:52:16 EDT
Improvements on this issue pushed to UF master and 0.3.x branches:

https://github.com/droolsjbpm/uberfire/commit/73f2d5e33
https://github.com/droolsjbpm/uberfire/commit/8843e50e5
Comment 10 Radovan Synek 2013-10-16 02:38:39 EDT
Verified on BPMS-6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.